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Notice
The information in this document is subject to change without prior notice in order to improve
reliability, design, or function and does not represent a commitment on the part of this company.
In no event will we be liable for direct, indirect, special, incidental, or consequential damages
arising out of the use or the inability to use the product or documentation, even if advised of the
possibility of such damages.
Copyright © 1997 - 2010 SoftLab-NSK Ltd.
All Rights Reserved.
No part of this reference manual may be reproduced or transmitted in any form or by any means
without the prior written permission of this company.
Throughout this manual, we make reference to product names that are trademarks of other
companies. We are using these names for identification purposes only, with no intention of
infringement of the trademarks.
FCC Information
FCC ID:
This equipment has been tested and found to comply with the limits for a Class B digital device,
pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection
against harmful interference in a residential installation. This equipment generates uses and can
radiate radio frequency energy and, if not installed and used in accordance with the instructions,
may cause harmful interference to radio communications. However, there is no guarantee that
interference will not occur in a particular installation. If this equipment does cause harmful
interference to radio or television reception, which can be determined by turning the equipment
off and on, the user is encouraged to try to correct the interference by one or more of the following
measures:
Reorient or relocate the receiving antenna.
Increase the separation between the equipment and receiver.
Connect the equipment into an outlet on a circuit different from that to which the receiver is
connected.
Consult the dealer or an experienced radio/TV technician for help.
Shielded cables and I/O cards must be used for this equipment to comply with the relevant FCC
regulations. Changes or modifications not expressly approved in writing by SoftLab-NSK Ltd. may
void the user’s authority to operate this equipment.
Limited Warranty
Our company warrants this product against defects in materials and workmanship for a period of
one year from the date of purchase. During the warranty period, products determined by us to be
defective in form or function will be repaired or replaced at our option, at no charge. This warranty
does not apply if the product has been damaged by accident, abuse, misuse, or as a result of service
or modification other than by us.
This warranty is in lieu of any other warranty expressed or implied. In no event shall we be held
liable for incidental or consequential damages, such as lost revenue or lost business opportunities
arising from the purchase of this product.
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Introduction
The RemoteOnAir plugin is designed to control a process of
broadcasting distantly and provides with a remote access to
broadcasting server. Operating machines can be located in the
limits of a local network or interact by means of the Internet
(VPN).
The plugin allows connecting with the FDOnAir main
application window and implementing the following remotely:
●● to control a broadcasting process: current playback
state, block remain time etc.;
●● to control a playback of audio/video data (passthrough
video, ads, titles overlayings) by means of interactive
control buttons and hot keys;
●● to load schedules from files to FDOnAir and control its
execution.
Advantage of the plugin in comparison with other systems of
remote access is in text strings (internal FDOnAir commands)
used for machines interacting. This factor creates a minimal
network load and provides with a high speed of interaction.
You may get a remote access to several FDOnAir instances
working with the only RemoteOnAir plugin instance. Also,
you may get an access to one FDOnAir instance from different
machines with the installed plugin.
There are 2 types of the RemoteOnAir product:
●● RemoteOnAir4 – designed for dealing with 4 FD300
boards;
●● RemoteOnAir16 – designed for dealing with 16 FD300
boards.
Boards can be plugged into one/several machines.
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General Workflow
The RemoteOnAir plugin is an additional program option.
Installation is implemented on machine from which a remote
control over broadcasting server will be executed. The plugin
requires a registration key. For more information on this issue
see the «Plugins Setup» user's guide.

88 Important: Complete the following to control FDOnAir remotely:

1. Install software with identical versions on used machines.
2. Switch firewall on machines off or add exceptions for the
SLMessageServer2 service (for more information on this issue,
see the SLMessageServer2 section).

Complete the following steps to prepare for working
with FDOnAir remotely (detailed information is given in
corresponding sections below):
1. Configure necessary FDOnAir application instance on a
broadcasting server. Prepare broadcasting schedule. Load
title project.
In the FDOnAir application select Settings > Mirroring and put
the «Receive and execute commands» check mark. The option is
necessary for further working with the RemoteOnAir plugin.
2. Launch the RemoteOnAir plugin on machine from which
a remote control over broadcasting will be implemented.
The following steps are implemented in the RemoteOnAir
program window.
3. Specify connection parameters: hostname where
broadcasting server is launched and corresponding FDOnAir
application instance index. A new operating panel to control
broadcasting server is added to the RemoteOnAir program
window.
4. Configure the panel by adding necessary blocks of buttons
and indicators to control broadcasting server.
Note:

If you need to have a remote access to different FDOnAir instances
implement the 1, 3, 4 steps to make configuration for each instance.
In this case several operating panels appear in the RemoteOnAir
program window.

5. Switch from edit to work mode in the RemoteOnAir
program.
6. Launch all necessay FDOnAir instances and connect to each
of the instances from RemoteOnAir.
7. If connection is correctly set buttons and indicators on
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RemoteOnAir operating panel display current state of a
corresponding FDOnAir instance. Clicking the buttons on
panel corresponds clicking the buttons in the FDOnAir
window.
8. All connections will be automatically disconnected if
the RemoteOnAir application window is closed. At the
next launch the application will be opened in edit mode.
Complete the 5,6 steps to connect with broadcasting server
again.
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Configuration of the FDOnAir Application for Receiving Commands
(Step 1)
Complete the following steps for the FDOnAir application to
execute the commands received from the RemoteOnAir window:
1. Launch necessary FDOnAir application instance on a
broadcasting server.
2. Click the Settings button (1) in the main application window.

1

3. Pass to the Mirroring tab (2) in the Settings window.

2
3

4
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4. Put the Receive and execute commands check mark (3) to allow
receiving external commands from other applications (the
RemoteOnAir plugin in our case) and executing them.
5. Then click Close (4) to save the settings and close the
window.
6. The Disable/enable receiving of mirror commands button (5)
becomes active in the main application window.
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7. Note that this button has 2 states. Color of the button
indicates its state:
●● red – commands are not allowed to be received;
●● grey – commands are allowed to be received.
Single clicking of the button disables receiving of commands,
the next clicking enables it.
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Launch of the RemoteOnAir Program (Step 2).
RemoteOnAir Projects Handling
Note:

The RemoteOnAir project is a set of operating panels configured by
user that provide with a remote access to FDOnAir. Projects are
stored in the *.SLRemOnAirCfg files.

1. Launch the RemoteOnAir application via Start:

Programs > ForwardT Software > Plugins > RemoteOnAir.

At first program launch main application window with
an empty project appears. During subsequent launches
the latest saved project appears. The program is always
launched in edit mode.
2. Click File > New (1) in the main program window to create a
new project. Click File > Open (2) to open the existing one.
1

2

3

3. Add and adjust necessary operating panels. Then save the
project via the File > Save project or Save project as... menu
command (3).
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Adding of Panels to Control FDOnAir (Step 3)
User manually creates operating panel in the RemoteOnAir
main window for each of the FDOnAir program instances.
Adding and configuring are implemented in edit mode (when
the Edit mode check mark in the Commands menu is put).
1. Use the Commands > Edit mode > Add OnAir command (1) in the
main program window to add new panel to control FDOnAir
remotely.

1

In the Add OnAir appeared window:
2. Specify name of configuration (2). The name will be
displayed in the panel title bar.

2
4

3
5
6

3. Specify hostname (LAN name/IP address/DNS) in the Host
name field (3). Open the window for selecting machine in
local net using the ... button (4).
4. Specify index of application instance in the
OnAir number field (5).
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5. Click OK (6) to apply the settings.
6. New panel (7) appears in the main program window. The
Connect button and an indicator also appear. In edit mode
the button is inactive, indicator displays disconnection.

7
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Configuration of a Panel (Step 4)
RemoteOnAir working panel can be configured for a specific
purpose by adding required groups of control elements (buttons
and indicators). You may put them in a place more conveinient
for you if needed. Also, there is a possibility of adjusting hot
keys to buttons.

1. Blocks of Control Elements
Available blocks of elements are located on the Elements panel (1) in
the main program window. The panel is available in edit mode.
1

Main program window in edit mode. Example of panel customizing.

Most of the elements on this panel (according to the purpose
and its appearance) correspond to control elements of the
FDOnAir main application window. For more information on
elements see the «FDOnAir. Broadcast Automation» user's
guide.
Detailed information on blocks is given below. Pictures present
blocks appearance when RemoteOnAir is in work mode and is
connected with FDOnAir.
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1. Ads insertion block: provides with a minimal set of elements
to control a full-screen playback.
2

3

4

5

1
Block for ads insertion:

1 – default picture № 1 on; 2 – switch broadcasting of a passthrough video
from Input 1 on; 3 – the Start block command (more detail see below); 4 – the
Skip block command (detailed information is given below); 5 – string with
information on the first command in current block (command of new block
start).

The Start block command (example of command use is
given below on the figure) interrupts execution of the
current command from schedule (1) and launches the next
one (2) – a command in which string there is the «next
command» indicator (3). In this case the indicator is moved to
the next string.

3
1
4

2
5

1

Fragment of a panel. Blocks of ads insertion, control of background and schedule:

1 – currently executing command; 2 – the next command for being executing; 3 – the next command
mark; 4 – start of block; 5 – the first executing command in block.

The Skip block command shifts the next command indicator (3)
to the first command of the next block (the Wait particular time
command (4)) and switches schedule to the «Pause» state.
In this state the current command will be executing till the end.
Then execution of schedule stops. Click the Start block button
for further execution of the schedule. In this case the command
that follows start block command (5) will be executing.
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2. Time block: provides with indicators to control time.

2

1

3
Time block:

1 – current time in FDOnAir; 2 – period of time from start of the current
command execution; 3 – remain block time.

3. Background control blocks: provides with controlling
elements and a possibility of interactive control over a
fullscreen broadcasting.

2

1
3

4
6

5

А

B
Background blocks: main (А), reduced (B):

1 – display default picture № 1/2; 2 – broadcasting of a passthrough video
from Input 1 – 6 (the Input 1–6 command); 3 – crossfade duration slider
(active when clicking the F1–F5, F3–F5 buttons); 4 – cancels audio file
playback, schedule is in «Pause» state in this case; 5 – current playback
indicator (displays data on broadcasting of video/audio data/pauses/ remain
time from/till playback finish); 6 – the Wait finish option.
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4. Titles control blocks: provides with controlling elements and
a possibility of interactive control over titles overlayings.
1

2

3

4

5

6

7

А

B
Blocks of titles control: main (А), reduced (B):

1 – title objects on/off; 2 – logotype on/off; 3 – logo/titles fade duration slider (active
when working with buttons for title control);
4 – fullscreen titles playback indicator (for video and transparent pictures), displays file
name and remain playback time; 5 – the Wait finish option; 6 – the Clear fullscreen
title command; 7 – buttons to control title objects assigned to the F9–F12, F9–F12
buttons.

5. Audio control block: provides with elements to control audio
playback.
1

2

3

Audio control block:
1 – the Auxiliary audio on/off command; 2 – the Set min audio level

command; 3 – area to control audio lines.
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6. Schedule block: provides with 2 schedule tables
corresponding to tables in the main FDOnAir application
window.
You may control a process of schedule executing: current
block, the next command, specified time of blocks start,
information on errors.

6

7

1

2

4

3

5

Fragment of a panel. Blocks with time, control over background, insertion of ads and schedule:

1 – first schedule table; 2 – second schedule table; 3 – progress bar (displays a process of current block
executing); 4 – the next command for being executed; 5 – edit position indicator; 6 – show start time from
run position on/off; 7 – show start time from edit position on/off.

It is impossible to switch from one table to another one
manually to change executable schedule. It can be done
automatically via the Switch to other schedule command or
using schedule autoload option.
It is impossible to add/delete manually separate commands
to the schedule table. You may load in selected table
a schedule from file instead/in addition to a currently
executing one. In this case use ScheduleEdit block (more detail
see below).
Usually in work mode only for start block commands start
time is displayed. For other commands time is displayed only
if a corresponding option is on. To switch this option on use
the (6, 7) buttons.
There are 2 ways of start time displaying that can be
switched on/off independently:
1. Enable displaying of start time of commands located in
the current executing position and below it (1).
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1

2. Enable displaying of start time of commands located in
the current editing position or below it (2).

2
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7. Schedule editing block: elements of this block correspond
to a group of Schedule file pages in the main FDOnAir
application. A list of schedule files from specified folder is
displayed on each page.
1

3

5

4

2

ScheduleEdit block:

1 – tabs corresponding to FDOnAir tabs with schedule pages; 2 – list of schedules;
3 – insert mode; 4 – overwrite mode; 5 – refresh files list.

Complete the following to load schedule from file into
specified table:
1. There are 2 edit modes:
●● Insertion – adding of strings of loading schedule to
already present in table, below a string with indicator;
●● Replacement – deleting of the current schedule from
table and load a new one.
Select a necessary one by clicking a corresponding button.
2. Place current position indicator in required schedule
string.
3. Double-click name of file with schedule.

1
3

2
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2. Adding of Blocks on Panel
Select necessary block on the Elements panel (1) by clicking and
dragging it to operating panel (2).

1

2

a

b

3. Hot Keys
Complete the following to adjust hot keys:
1. Select Commands > Shortcut Config (1) in the main program
window.

1

2. Select name of operating panel to which hot key is adjusted
in the OnAir drop-down list (2), Morning_Air is in our example.
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3. Select elements block in the Control drop-down list (3). Table
with the list of commands (4) displays only those commands
that correspond to the buttons of the selected block.

3

2

4

4. Select necessary command by clicking a string with it in the
table.
5. Set a cursor in the Press shortcut key field (5).
6. Press a button/combination of buttons on keyboard that
correspond to the selected command. Its name will be
displayed in the Press shortcut key field.
7. Click Assign (6).

4

5
6

20

8. Name of assigned key is added to string with the
command (7).

7

9. Assign other keys by repeating steps 4–7.
10. Click Close (8) to apply the settings and close the window.

8
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Remote Access to FDOnAir (Steps 5, 6)
When configuration is complete toggle to the Work mode
in RemoteOnAir and connect with broadcasting server by
completing the following steps:
1. Open the Commands menu and put the Edit mode check mark (1)
off by clicking it.

1

2. The application toggles to Work mode. The Connect button (2)
on panels becomes active.
2

3. Click Connect on corresponding panels to connect remotely
with corresponding FDOnAir program instance.
4. If there is a connection the indicator (3) becomes green.
Name of the button turns into Disconnect (4). State of buttons
on panel (5) of the RemoteOnAir program correspond to
state of buttons of the FDOnAir application.
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3
4

5

5. To check if connection is correct click any of the buttons on
the panel and be sure that the same button is clicked in the
FDOnAir application, for example, F3 (6) and F8 (7).

7
6
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6. The F3 (8) and F8 (9) buttons will be active in the main
FDOnAir window on remote machine.

7. Put the Edit mode check mark in the Commands menu to
toggle from Work mode to the edit one.
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Additional Information: Configuration of Firewall
Configure Firewall (switch it off/configure exceptions for the
SLMessageServer2 service) for a remote control over the
FDOnAir application.
Complete the following on each machine if Windows Firewall (is
on) is used:
1. Open Control panel via Start: Settings > Control Panel.
2. Double-click Windows Firewall (1).

1

3. Be sure that On (2) is selected (the General tab) in the
appeared window.
The following steps are implemented in this window.

2
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4. Pass to the Exceptions tab (3) and click the Add port...
button (4).
3

4

5. In the Add a Port window:
1. Be sure that TCP (5) is selected.
2. Specify name of a service (SLMessageServer2) in the Name
field (6).
3. Specify SLMessageServer2 port number in the Port number
field (7).
Port 51051 is used by default.
4. Click OK (8) to apply the settings and close the window.

6
7
5

8
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6. Specified item is added to the Programs and Services list (9).

9

10

7. Click OK (10) to save the settings and close the window.
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Useful Links
ForwardT Software set: description, download, documentation, solutions
http://www.softlab-nsk.com/forward/index.html

Support
e-mail: forward@sl.iae.nsk.su
forward@softlab-nsk.com

Forum
http://www.softlab-nsk.com/forum (currently available in Russian only)

Documentation for more information:
1. Plugins Setup. User's Guide.
2. FDOnAir. Automation Broadcasting. User's Guide.
3. FDOnAir Commands. User's Guide.
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