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Notice
The information in this document is subject to change without prior notice in order to improve
reliability, design, or function and does not represent a commitment on the part of this company.
In no event will we be liable for direct, indirect, special, incidental, or consequential damages
arising out of the use or the inability to use the product or documentation, even if advised of the
possibility of such damages.
Copyright © 1997 - 2009 SoftLab-NSK Ltd.
All Rights Reserved.
No part of this reference manual may be reproduced or transmitted in any form or by any means
without the prior written permission of this company.
Throughout this manual, we make reference to product names that are trademarks of other
companies. We are using these names for identification purposes only, with no intention of
infringement of the trademarks.
FCC Information
FCC ID:
This equipment has been tested and found to comply with the limits for a Class B digital device,
pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection
against harmful interference in a residential installation. This equipment generates uses and can
radiate radio frequency energy and, if not installed and used in accordance with the instructions,
may cause harmful interference to radio communications. However, there is no guarantee that
interference will not occur in a particular installation. If this equipment does cause harmful
interference to radio or television reception, which can be determined by turning the equipment
off and on, the user is encouraged to try to correct the interference by one or more of the following
measures:
Reorient or relocate the receiving antenna.
Increase the separation between the equipment and receiver.
Connect the equipment into an outlet on a circuit different from that to which the receiver is
connected.
Consult the dealer or an experienced radio/TV technician for help.
Shielded cables and I/O cards must be used for this equipment to comply with the relevant FCC
regulations. Changes or modifications not expressly approved in writing by SoftLab-NSK Ltd. may
void the user’s authority to operate this equipment.
Limited Warranty
Our company warrants this product against defects in materials and workmanship for a period of
one year from the date of purchase. During the warranty period, products determined by us to be
defective in form or function will be repaired or replaced at our option, at no charge. This warranty
does not apply if the product has been damaged by accident, abuse, misuse, or as a result of service
or modification other than by us.
This warranty is in lieu of any other warranty expressed or implied. In no event shall we be held
liable for incidental or consequential damages, such as lost revenue or lost business opportunities
arising from the purchase of this product.
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General Information about the PostPlay System
1. Function
PostPlay is a broadcast delay system based on the FD300 board.
The function of the system is recording and storing in digital
form audio and video data coming with a television signal as
well as providing access to them in order to preview and play
back.
The system allows you to shift the broadcast by a specified time,
from several minutes to several days and output data on air in
two modes:
●● with a fixed delay without changing the broadcast
schedule;
●● with the schedule rearrangement.
Recording the broadcast can be performed concurrently with
playing data on the same computer. It is possible to build
a distributed system, when recording is performed on one
computer, controlling and retransmitting – on another.

2. Storage
Storages are used to store data in the PostPlay system.
Physically a storage is a set of files on the computer hard disks,
logically being a continuous cyclical data array.
Each storage has a name and volume or size – an amount of
data held (measured by time), that is maximal delay time when
rebroadcasting.
A storage is filled with data «in a circle». Within the allocated
space, data are recorded in succession. If the duration of a
record exceeds the storage capacity, the currently «oldest» data
are started to be erased, the newly coming being saved instead
of them.

3. Clip
Clips are used to work with a record fragments. A Clip is a
named data fragment located in the storage and corresponding
to a certain time interval. Many clips can be separated within a
storage.
Creating and editing a clip adds up to specifying its name and
the bounds of the required time interval; deleting – to deleting
the information about the clip. All the operations do not cause a
change in the video and audio data in the storage.

4. The System Components and Functions of the Programs
The PostPlay system is a program server for storing data and a
set of client programs for the server.
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There are two variants of the system: for single-channel data
input (PostPlay) and multichannel data input (PostPlay2).

The PostPlay system includes the following components (see the
diagram):
●● FDPostPlay Indicator is a program used to set and
display the PostPlay system current status, start/stop
the services, launch the setting programs and client
applications;
●● client programs:
●● FDPostPlay VideoIn – to input video and audio
data, create and control storages;
●● FDPostPlay VideoIn2 – for the multichannel input
of video and audio data; to create storages and
control them (included in PostPlay2 only);
●● FDPostPlay Preview – to preview data in the
storages, create, edit, and delete clips, export data
from the storages to video files;
●● FDTimeShift – to rebroadcast TV signal with a
fixed time shifting.
The PostPlay system operates on the FD300 board.
To set the board, the following programs are used:
●● FDConfiguration – to set the FD300 board parameters;
●● FD300 Sound Control – to set sound mixing on the
FD300 board.

5

5. General Scheme of Using the PostPlay Software
The table below shows the general scheme of using the
programs: typical tasks and programs designed to perform
them.
Task

Subtask

Programs

Previewing Data in the Storage and
Creating Clips

Recording Data
Configuring
Storages

Input

FDPostPlay VideoIn/
FDPostPlay VideoIn2

Outputting Data

Previewing Data

Creating Clips

Rebroadcasting
with a Fixed
Delay

FDPostPlay Preview

– in manual mode:
FDPostPlay Preview
– in automated
mode:
MS Excel macros;
importing a list of
clips from a CSV file

FDTimeShift

Clips in an
Arbitrary
Order
according to
the Schedule

FDOnAir

6. FDPostPlay Indicator – Launching the Programs
The main setting programs and client applications of the
PostPlay system can be launched via the FDPostPlay Indicator
program. The program icon is located in the system tray.

To open the programs, right-click on the FDPostPlay Indicator
icon. Use the contextual menu commands.
Commands

Programs

Start Video In 2

FDPostPlay VideoIn2

Start Video In

FDPostPlay VideoIn

Start Preview

FDPostPlay Preview

Start OnAir

FDOnAir

FD300 Sound Configure

FD300 Sound Control

Advanced... > FD300 Configuration

FDConfiguration
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Rebroadcast Modes and Procedure of using the Programs
There are two modes of rebroadcasting data. The composition
and procedure of using the PostPlay programs depend on the
selected mode.

1. Rebroadcasting with a Fixed Delay without Changing the Broadcast Schedule
In this mode, rebroadcasting data received from the head-end
station is shifted by a required time, the data being played in
full and in the original order. Inserting local commercials is not
performed. In this mode, the maximal delay time cannot exceed
twenty-four hours.
The procedure of using the programs when working in this
mode is shown in the diagram.

2. Rebroadcasting with the Schedule Rearrangement
In this mode, in addition to time shifting, it is possible to
change the order of playing data received from the head-end
station. It is possible to insert local blocks, e.g., change some
fragments to local news, insert commercials, programs, films,
etc.
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To rebroadcast data from the storages in this mode, use the
clips. Using them, it is possible to manage playing any required
fragment of the storage.
The procedure of using the programs when working in this
mode is shown in the diagram.

88 Important: When the FDPostPlay VideoIn application is running, the

ability to switch between different video signal sources in the
FDOnAir program is disabled. In the FDOnAir program, only
the source selected in FDPostPlay VideoIn is available.
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Recording Data to the Storage
Data input is performed via the FDPostPlay VideoIn program
(for a detailed description of the program, see FDPostPlay
User's Guide) or FDPostPlay VideoIn2 (for a detailed
description of the program, see FDReplayVideoIn User's Guide).
The procedure of working with the FDPostPlay VideoIn
program is discussed in the next Sections.

General Order of Operations
Step 1. Checking the FD300 board connections and settings in
the FDConfiguration application.
Step 2. Launching the FDPostPlay VideoIn program.
Step 3. Setting connections in FDPostPlay VideoIn.
Step 4. Selecting a storage.
Step 5. Configuring the storage.
Step 6. Controlling the data input.

Step 1. Checking the FD300 Board Connections and Settings in the
FDConfiguration Application

1. Launch the FDConfiguration application using the program
shortcut located on the desktop or via the Start menu: Programs > ForwardT Software > Board Setup > FD300 Configuration,
as well as selecting Advanced... > FD300 Configuration of the
FDPostPlay Indicator contextual menu.
2. Connect the video signal source to the FD300 board video
input.
3. Select a board in the Boards’ Indexes list (3).
4

3

6
5

4. Select the Line A tab (4). In the Input drop-down list, select
the FD300 board video input to which the video signal
source is connected.
5. Make sure an image from the selected video signal source

9

is displayed in the Line A preview pane (5), which means the
connection was made correctly.
6. Remember the line name (6). In our case: CVBS4(1C).
7. Select the Format tab (7). Select a TV standard in the
TV Standard drop-down list and make sure the FullFull size is
selected in the Image Size drop-down list.
7

8. Select the Sound tab (8). Select a mode of operation of the
FD300 board audio subsystem and audio sample rate in the
Audio device type and Internal processing sample rate drop-down
lists respectively.

88 Important: Make sure the video and audio synchronization mode is

enabled, that is the Allow low level audio/video synchronization check
box is checked. Otherwise, audio and video synchronization is
not guaranteed.
8

9

9. Click OK (9) to save the settings.
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Step 2. Launching the FDPostPlay VideoIn Program
Launch the FDPostPlay VideoIn program using:
●● the shortcut located on the desktop;
●● the Start menu: Программы > ForwardT Software > PostPlay
> VideoIn;
●● the Start Video In command of the FDPostPlay Indicator
contextual menu.

Step 3. Setting Connections in FDPostPlay VideoIn

1. Click the Video... button (1) in the FDPostPlay VideoIn main
window. The FDTM Board Properties window opens.

1
9

2. Select the Format tab (2).
2

3
4
5
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3. From the Board index drop-down list (3), select the board to
which the video source is connected.
4. Select a TV standard in the TV Standard drop-down list (4).
Make sure FullFull is selected in the Image Size drop-down
list (5).
5. Select the Input tab (6).
6

7

8

6. From the Input drop-down list (7), select the input line to
which the video signal source is connected. The correctness
of the connection is checked in the FDConfiguration
application (see Step 1 paragraphs 2–6).
7. Click OK (8).
8. Click the Audio... button (9) in the FDPostPlay VideoIn main
window. The FD300 audio source window opens.
9. Select an audio device on the selected board (10) and the
audio capture channel (11) (when monophonic recording).

10

12

11

10. Click OK (12).
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Step 4. Selecting a Storage
Specify a storage to which data will be recorded:
●● if existent, select in the drop-down list (1). If
necessary, click the Configure... button (2) and change
the storage settings;
●● if new, click the Create new... button (3) and configure a
new storage.
2
1
3

Step 5. Configuring the Storage
For more details about configuring the storage, see FDPostPlay
User's Guide.
1. The existent or new storage is configured in the Storage
configuration dialog box. To open the dialog box, click the
Configure... or Create new... button respectively in the main
application window.

88 Important: Be careful when editing the existent storage settings (except for
the name). When applying changes (clicking OK), all the data
held in the storage is discarded!
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2. If necessary, change the storage name (2).

2
3

8

4
5

7
6

3. Specify the storage capacity (3) – the data amount stored (in
hours and minutes).
4. Select a video codec in the drop-down list under Video (4).

gg

Tip: It is recommended to use video codec SoftLab-NSK MPEG2 I-frames
with data rate from 4000 to 6000 KBPS as having the most
optimal operation speed and requiring less processing power
with the same resultant image quality compared with other
codecs.

5. Allocate the disk space for storing video data (5).

gg

Tip: When allocating the disk space for the storage (both for video
and audio data), we strongly recommend:
1. Do not locate the storage on the system disk.
2. Do not allocate all the free disk space for the storage –
reserve at least 5–10 GB for the system.

6. In the Channels drop-down list (6) under Audio, select
the number of channels used to capture audio. When
monophonic recording is selected, the channel specified in
Step 3 paragrapg 9 will be used for the audio data input.
7. Allocate the disk space for storing audio data (7).

88 Important: Time Shift (8) is other than broadcast delay time.
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Step 6. Controlling the Data Input

1. Recording data is controlled by the following buttons:
●● Start (1) – start recording;
●● Stop (2) – stop recording.
1

2

4

3

2. It is possible to input data according to the schedule – in
accordance with the list of events (3). Click the Events
button (4) to switch to operation according to the schedule.
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Previewing Data in the Storage and Creating Clips
The FDPostPlay Preview program is designed to preview data
input to the storage and create clips (for a detailed description
of the program, see FDPostPlay User's Guide).

1. Launching the FDPostPlay Preview Program
FDPostPlay Preview is launched using the shortcut on the
desktop or via the Start menu: Programs > ForwardT Software
> PostPlay > Preview, or by the Start Preview command of the
FDPostPlay Indicator context menu.
When launching the program, perform the following steps:
1. Select a computer on which the storage is located:
●● local – the computer on which the program is running;
●● remote – another computer, there being a connection
to it via the network.

2. Select a storage.
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3. The main application window opens.

2. Previewing Data in the Storage

1. The storage is selected when launching the program.
If the main program window is already open, it being
necessary to open another storage, use the Storage > Open...
command in the main program menu.
2. A schematic view of the whole storage is displayed in the
Overview area (1):
●● pink – a section in the storage that is occupied by data;
●● gray – a section in the storage that is free from data;
●● colored rectangle – a section in the storage that is
corresponding to the clip selected in the list of clips.
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7

9

6

1

10

2
5
3
4

8

3. A special indicator displays the status of data input to the
storage (2):
●●

4.

5.
6.

7.

performed –

;

stopped –
.
Data corresponding to the selected section of the storage are
displayed with the following elements of the main window:
●● video track (3) displays the video data;
●● audio track (4) – the audio waveform image;
●● time ruler (5) – the time values corresponding to video
and audio data.
The data display scale can be changed: zoomed out to
displaying the storage entirely or zoomed in up to displaying
data accurately within a frame.
The time indicator (6) displays the time corresponding to the
current position within the storage.
The current position within the storage can be selected
using:
●● the time ruler (5) – click at the required position on
the ruler;
●● commands of the Move menu (7);
●● the time indicator (6) – double-click on the indicator to
select time and date.
The video data can be previewed in the Video Preview
pane (8) of the program window or on the external monitor
via the FD300 board.
●●
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The preview playback is controlled using commands of the
View menu or the toolbar buttons:
●● Start playback (9);
●● Stop playback (10).
The preview playback parameters are configured in the
Preview playback properties dialog box. To open the dialog box,
select Options > Playback in the program main menu.

3. Creating Clips
Information about the open storage clips is displayed in the list
of clips (1).
To create, edit, delete clips, use the Clip menu commands,
toolbar buttons, contest menu of the list of clips.
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3

4

5

2

1

To create a clip, perform the following steps:
1. Place the cursor at the beginning of the clip accurately
within a frame (2).
2. Mark the beginning of the clip (3).
3. Place the cursor at the end of the clip accurately within a
frame.
4. Mark the end of the clip (4).
5. Add the clip to the list (5).
Also, to mark the beginning and end of the clip and add it
to the list, it is possible to use the keys Home, End, and Insert
respectively.
The process of creating clips can be automated using:
●● a macro that adds clips on the basis of the playlist.
To do so, use the Microsoft Office Excel program (see
Creating PostPlay clips using a macro in MS Excel.
User's Guide);
●● import from a CSV file (see FDPostPlay User's Guide).
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Rebroadcasting with the Schedule Rearrangement
In this mode, data from the storages received from the headend station as well as local blocks (local commercials, programs,
etc.) can be played on air in the required order.
Previously, create a storage (in the FDPostPlay VideoIn
program) and clips (in the FDPostPlay Preview program).
To broadcast data in this mode, it is necessary to create an
appropriate schedule based on the clips and local blocks.
To create a schedule and broadcast data on air, use the
FDOnAir program (for a detailed description of the program,
see FDOnAir User's Guide).
To launch FDOnAir, use the shortcut located on the desktop
or the Start menu: Programs > ForwardT Software > OnAir, or the
Start OnAir command of the FDPostPlay Indicator context menu.
Before creating the schedule, make sure the required clips exist
in the storages.
To add a Play video clip command to the schedule, perform the
following steps:
1. Click the PostPlay button (1) to open the PostPlay panel.
1

2

2. Click the Customize button (2) to enable the panel controls.
3. In the RPM Server drop-down list (3), select a computer, on
which the storage is located: local or remote.

3
5

4

6

4. In the RPM Storage drop-down list (4), select a storage
name. If no storage name is selected, the PostPlay panel
automatically displays the list of clips of all the storages of
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the selected RPM server.
5. Place the insert marker (5) in the schedule line that will be
followed by the Play PostPlay clip command. To do so, leftckick to the right of the Name column.
6. Select the required clip on the tab page (6) and double-click
on it.
7. A Play PostPlay clip command for playing the selected clip is
added to the schedule (7).
8

7

8. Likewise, add the commands for playing all the required
clips in the required order to the schedule.
To start broadcasting the schedule on air, click the Start
button (8).

88 Important: By the time of broadcasting a clip, the required data must exist
in the storage.



Example: Let us consider an example of rebroadcasting programs received

from the head-end station with time shifting and inserting
commercials.
The schedule fragments of the head-end station and a local
station broadcasting.
Head-End Station
Time

Program

Local Station
Time

Program

5:00

Pets for Life
Part 1

8:00

Pets for Life
Part 1

5:10

Break for Local
Insertions

8:10

Block of
Commercials

5:11

Pets for Life
Part 2

8:11

Pets for Life
Part 2

Programs received from the head-end station are rebroadcast
with a time shift of 3 hours. Local commercials are inserted into
the Break for Local Insertions.
To organize broadcasting in such a mode, perform as follows:
1. Record data received from the head-end station to the
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storage in the FDPostPlay VideoIn program.
2. Cut clips in the FDPostPlay Preview program.
Create two clips of the Pets for Life program (for the schedule
fragment). The beginning of the first clip – 05:00:00.00 (1),
end – 05:10:00.00. The beginning of the second clip –
05:11:00.00, end – 05:25:00.00.

1

3. Create a schedule in the FDOnAir program.
Insert an Active wait command first in the Morning show
(8:00:00.00). Then, a Play PostPlay clip command for
playing the clip Pets for Life Part 1. The clip starts on air
at 8:00:00.00 (2). Then Play PostPlay clip commands for
playing commercials (start – 8:10:00.00). After the block of
commercials, Pets for Life Part 2.

2
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When operating according to the created schedule, the time
shift between the on-air-broadcast time of the program (2)
and its storage beginning mark (1) is three hours, which is the
required delay time.
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Rebroadcasting with a Fixed Delay without Changing the Broadcast
Schedule
In this mode, you can only shift the time of broadcasting data
received from the head-end station (delay from 10 seconds to
twenty-four hours), the data being played in full and in the
original order. Inserting local commercials is not performed.
First of all, create a storage and start data capture in the
FDPostPlay VideoIn. The storage capacity must exceed a
maximum desired delay time by one minute.
To rebroadcast with a fixed delay without changing the
broadcast schedule, use the FDTimeShift program. To open the
program, select:

C:\Program Files\ForwardT Software\PostPlay\FDTimeShift.exe

To prepare broadcast, perform the following steps:
1. Set the delay time (1).

1

2

3

4

2. Select a board and storage (2):
●● select a board on which data is to be played;
●● select an audio line used to output audio data;
●● select a storage to which data is captured.
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Broadcasting is controlled by the following buttons:
●● Start (3) – start playback;
●● Stop (4) – stop playback.

88 Important: 1. The FDPostPlay VideoIn program must be running,

capturing data to the storage being performed!
2. Make sure the data corresponding to the playback start time
is held in the storage (that is, current time = data capture start
time + delay time).
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Useful Links

ForwardT Product Line: Description, Software Delivery, Documentation, Ready
Solutions
http://www.softlab-nsk.com/forward/index.html

Tech Support
http://www.softlab-nsk.com/support.html
e-mail: forward@softlab.tv
forward@sl.iae.nsk.su
forward@softlab-nsk.com

Forums
http://www.softlab-nsk.com/forum (currently available in Russian only)
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