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Introduction
The SLNewsTitler program is used for interactive control
of title elements in TV programs. An example would be the
display of caption with information (last name, first name,
occupation) about the people onscreen during news segments or
in live discussions. The program can also be used for interactive
control of the background: input video (from FD300/FDExt
board inputs) and video clips from the hard drive.
The SLNewsTitler program is a plugin for the Forward T and
Forward TS product lines. The program is based on products
that use FD300/FDExt boards. It is purchased separately from
the main product and requires an additional registration.
Note

To prepare the program for use, the user needs to understand how
to work with titles within the base Forward T products themselves.
For information on title projects, title objects and elements, see the
«FDTitleDesigner. Title Project Editor» user’s guide.

An example is delivered with the product that can help during
the first steps of using the program. The example’s files are in
the folder ~\FDTitle\SLNewsTitler_Sample, where ~ is the full
path to the folder containing the ForwardT Software.
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General information

Purpose
The SLNewsTitler program is designed to interactively control
overlaying titles to a passing video signal. Furthermore, it can
be used to interactively control the translation of video from
FD300/FDExt board input and video files.

Functional characteristics
The SLNewsTitler program performs the following functions:
●● preparing to display titles:
●● configuring formatting templates based on title
projects;
●● filling in templates with specific information –
creating title pages;
●● interactive control of displaying title pages while
broadcasting;
●● operative editing of text data for titles (captions);
●● creating and editing playlists for playing in the
background;
●● interactive control of playlist playback;
●● preview of title pages.
Note:

Title formatting is done based on title projects. The FDTitleDesigner
program from the ForwardT Software is used to create title projects.
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Function modes
The program has two function modes:
1. Foreground (title) server – only the titles can be contrlolled. The
functions to prepare and display playlists are blocked.
2. Background (video) server and Foreground (title) server – both the
background and the titles can be controlled.
If necessary, the SLNewsTitler program can be used at the
same time as the FDOnAir program. If both programs are
running, only one can be working in Background (video) server
mode.
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Important: The use of the SLNewsTitle program in Background (video) server
mode makes it impossible for the FDOnAir program to work
in Background (video) server mode. The FDOnAir program can,
however, work in Foreground (title) server mode.

In order to turn off Background (video) server mode in FDOnAir,
complete the following:
1. Start FDOnAir (the SLNewsTitler program needs to be
closed.
2. Open the Settings window by pressing Settings in the main
program window.
3. In the Settings window open the Configuration tab.

1

2
3

4. Unflag the Use as background (video) server option (1) and
press Apply changes (2).
5. Close the Settings window by pressing Close (3).
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Terminology used
1. Title page
When using the SLNewsTitle program one can broadcast only
the titles prepared in the program – title pages (or pages with
titles).
Each page is created based on a template, created in the
SLNewsTitler program (see p. «2. Template»).
A page with titles is a page, created based on a template, for
each title element of which one specific value is set. Each page
with titles is named.
The page with titles is displayed by user command. Several
different pages with titles can be displayed at once (for the rules
of displaying pages, see p. «1. Controlling the display of pages
with titles»).
Pages with titles can stop displaying both by the command of
the user and automatically – when the display time all of the
title objects, contained on the page, has run out.

 Example:

The News.SLNewsTitlerProj project, delivered with the program, is
designed to create and display pages with titles of three types:
1. Titles to display the channel name (1) and the name of the
program (2). The display time – throughout the entire
program; the display will stop at the user’s command (at the
end of the program).
1

2

2. Titles to display the names of cities (areas) in which a story
is shot (3), and a crawl line with information on the story
(4). During different stories the information they display
should be different. The display time – throughout a story;
the display will stop by the user’s command at the end of the
story.
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3
4

3. Titles to display information about the person or thing
currently being shown. The display time – 10 sec; the
display will stop automatically.

An example of a formatted broadcast using the project described
above.
Video

Page with titles 1

Output image

Page with titles 2
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2. Template

A template is a prototype (layout) of a title page.
A template is configured in the SLNewsTitler program based
on a title project created in the FDTitle Designer program (see
p. «3. Title project. Requirements of use»).
You can create multiple different templates based on one title
project, depending on the presence of the title objects in the project
and the user’s needs.
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Important: When creating templates it is important to keep in mind that

when using the SLNewsTitler program you can broadcast
several title pages at once, but they must be created based on
different title projects.
You can not broadcast two or more pages with titles, created
using different templates but based on the same title project.
A title project can contain many title objects. Only those objects
that need to be simultaneously displayed on screen and started on
command by the user should be added to the template.
When configuring a template the user indicates:
●● the template name;
●● which title objects from the title project are included
in the template;
●● if you plan to create pages with titles based on this
template, then necessary title elements/objects are
selected, the assignments for which will be set by the
user when creating pages with titles, and they are tied
to their source of data for substitution;
●● the order in which the title objects appear/disappear
from the screen.
If the template contains elements for data substitution then
you can create multiple pages of the same type based on the
template to display differing data. The elements receive data for
substitution from the sources, set by the user (see p. «5. Sources
of data for substitution into templates»).
If the template does not contain title elements/objects for data
substitution, only one original page of titles can be created
based on it (if several pages are created, all of them will be
identical).
It is not possible to change the settings of the objects and
elements set in the title project when creating a template (such
as the coordinates, size, etc.), but you can set the order in which
the objects appear on screen and their display duration.
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 Example:

Let’s look at the templates Comment and Logo, contained in the
News.SLNewsTitlerProj project.
1. The Comment template is created based on the Comment.SLTitleProj title project.

The title project Comment.SLTitleProj in the FDTitle Designer window

editing mode

preview mode

The template contains all of the title element contained in
the Comment.SLTitleProj title project.
The title elements Town (1), Name (2), and Explanation (3)
are marked as elements for data substitution. These title
elements are Captions. When creating a page, they will be
filled in with text data from different columns of the Data.csv
file.
Comment template

1

2

3

Based on this template you can creates different pages with
titles.

Examples of pages with titles created based on the Comment template
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2. The Logo template is created based on the Logo.SLTitleProj
title project.
The title project Logo.SLTitleProj in the FDTitle Designer window

editing mode

preview mode

The template contains all of the title element contained in
the title project.
The Logo template does not contain any elements for data
substitution, and therefore only one page based on it can be
created.
Logo template

Page with titles created based on
the Logo template

3. Title project. Requirements of use
A title project is a layout of titles on screen. Created in the
FDTitle Designer program (contained in the ForwardT
Software). In the title project the composition (types and
amount), placement of title elements (using X, Y, Z coordinates),
combining title elements into groups, task files are set and so on
(see the «FDTitle Designer. Title Project Editor» user’s guide).
In the SLNewsTitler program a title project is used as a base
for templates. One SLNewsTitler project must contain at least
one title project.
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When creating title projects, designed to be used in the
SLNewsTitler program, keep the following requirements in
mind:
1. If several title projects will be used to create templates
in one SLNewsTitler project, then all of the title objects
in all of the title projects need to have different base
Z-coordinates.
2. It is impossible to broadcast multiple title pages, created
based on the same title project, at the same time.
Pages, created based on different title projects, can be
broadcast simultaneously.
If you need to broadcast several pages at once, make sure to
create different projects for each one.
3. For title elements/objects, the tasks of which will not change
when creating a page in the SLNewsTitler program, task
files must be set in the title projects.
4. For title elements/objects, into which data needs to be
substituted when creating a page in the SLNewsTitler
program, a task file does not need to be set.
5. In the SLNewsTitler program you can set a sequence of
broadcasting title objects as well as time intervals between
their broadcast.
6. For title objects, containing title elements with looped tasks,
you can set the broadcast duration of the element in the
SLNewsTitler program.
7. For unlooped elements, the broadcast duration is set in the
FDTitleDesigner program in the title element settings.
8. When naming title project files, keep in mind that their
names will be displayed in the SLNewsTitler program
window as headings for tabs with layers (see image in
section «4. Layer»).

 Example:

When working with the News.SLNewsTitlerProj project it is
expected to broadcast up to three different pages at once. As
it is impossible to simultaneously display several pages based
on the same title project, three title projects were prepared:
Town+Crawl.SLTitleProj, Comment.SLTitleProj, Logo.SLTitleProj.
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4. Layer
A layer is an area (in the main program window) for the display
of the page templates, created based on one title project.
The amount of layers in a project corresponds to the amount of
title projects used to create templates.
The layer names are set automatically and correspond to the
name of the title project files.

SLNewsTitler program

Layer tab
Logo
Layer tab
Comment

Title project
Comment.SLTitleProj

Title project
Logo.SLTitleProj

Title project
Town+Crawl.SLTitleProj

5. Sources of data for substitution into templates
Two types of data are used for substitution into templates:
●● a CSV file (see p. «6. CSV file»). Data from a CSV file
can be substituted only into Caption type element;
●● a Directory – a folder with task files for title objects/
elements (see p. «7. Directory»).
The linking of the title objects/elements of the template and
their sources of data are set when configuring the template.
The selection of data for substitution is done by the user when
creating a page with titles.
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6. CSV file
A CSV file is a text file with the csv extension that contains
table data in text format. Each line of the file is one line of a
table, where the data of separate columns is divided using a
special divider (semicolon character is typically used).
You can create a CSV file using the Notepad or Microsoft Excel
program.
The images below display the same CSV file opened in the
Notepad (a), Microsoft Excel (b), and SLNewsTitler (c).
3

1

2

а

1

b

1

c
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Particular qualities of CSV files used in the SLNewsTitler
program (see image above):
●● the first line must contain the column headings (1);
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Important: In the SLNewsTitler program the data in the first line of a CSV
file is considered to contain the headings of the columns and is
unavailable for substitution.
●● in order to separate different columns the following
can be used: a comma, a semicolon; a space, a tab
character (in our example a semicolon is used (3));
●● the data within all or some of the fields (table cells)
can be contained using the restrictors " (quotation
marks) or ' (apostrophe) (2).
Note:

Data is required to be contained within quotation marks (apostrophes)
in the following cases:
– if the data contains quotation marks;
– if the data contains a divider (for example, a semicolon);
– if the data contains a space.

Data from a CSV file can only be substituted into title elements
of the Caption type in the SLNewsTitler program.
Data from one column of the table, set when configuring the
template, is substituted into one title element.
Data from the same file can be used for elements belonging to
different objects (both in the same and in different templates).

7. Directory
A Directory is a folder containing task files for title objects/
elements.
Note:

A task file for a title objects is a file with the SLTitleTsk extension
that contains a list of tasks for the title elements contained in that
object. Tasks for title objects are created in the FDTitle Designer
program. Task files for title elements contain the data that will be
displayed in the titles.
For information on task files for title objects and title elements of
different types, see the «FDTitle Designer. Title Project Editor» user’s
guide.

All task files, designed to be substituted into one title object/
element, should be contained in one folder i.e. should be
contained within a Directory data source.
One directory can contain tasks for different title objects/
elements.

8. Pages group
Many title pages of different types can be created and used
in one SLNewsTitler project. For convenience, the user can
combine pages of the same type into groups.
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9. Playlist
To control the broadcast of video playlists are created in the
SLNewsTitler project. One project can contain several playlist.
Particular qualities of playlist playback:
●● playback starts by user command;
●● the playback of playlist elements is done in their
order:
●● when playback of a video file is finished, the next
element automatically starts playing;
●● switching from board input to playlist playback is
done by user command.

10. SLNewsTitler project
A SLNewsTitler project is the aggregation of all the necessary
settings for work (live broadcast of titles/background). Projects
are saved in files with the SLNewsTitlerProj extension.
A project is created in the SLNewsTitler program as the result
of the configuration of a work session. Contains information on
the selected mode of the program; on the used FD300/FDExt
board, title projects, sources of data for titles; created templates,
title pages, playlists.
A saved project can be used multiple times and in different
work sessions.
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Important: After creating and saving a project it is not allowed to change
the names and placement of the files/folder used (for title
projects, files, and data folder, video files, etc.).

„„

Tip: We recommend looking through the News.SLNewsTitlerProj
project that is delivered with the SLNewsTitler program.
The example files are located in the folder ~\FDTitle\
SLNewsTitler_Sample, where ~ is the full path to the folder
with the ForwardT Software.
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General procedure when using the program
Before live
broadcast

1. Designing the titles.
2. Preparing for the creation of title projects, based on which page
templates will be created:
–

deciding on the amount of title projects and the title objects/
elements contained within each;

–

creating the task files, style collections for the title projects.

3. Creating title projects in the FDTitleDesigner program.
4. Preparing data for display in titles during broadcast.
5. Creating a project in the SLNewsTitler program:

During live
broadcast

–

configuring page templates;

–

creating pages with titles;

–

creating a playlist (if using the program as the Background (video)
server).

Working in the SLNewsTitler program:
–

managing the broadcast of pages with titles;

–

if necessary, the addition of new data into sources, operative
creation and broadcast of new pages with titles;

–

managing the playlist playback (if using the program as the Background (video) server).
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Starting the program
The program is started when the ~\FDTitle\SLNewsTitler.exe file is
run, where ~ is the full path to the folder containing ForwardT
Software.
The program can also be run using the Start menu: Programs >
ForwardT Software > Plugins > SLNewsTitler.
When starting the program, the main window will open. The
main window only contains the main menu.

Additional windows and sections of the main menu appear if
you create or open an already created SLNewsTitler project.
To create a new project select File > New… (1).

19

Working with the program

Creating a new project

„„
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Tip: When learning the program we recommend systematically

following all of the steps listed below to create a SLNewsTitler
project.

Important: All of the necessary title projects and data for substitution into
templates (task files, CSV files) need to be prepared before
creating the project.

1. Starting work
1. Open the SLNewsTitler program using the Start menu: Programs > ForwardT Software > Plugins > SLNewsTitler.

2. In the main window select File > New... (1).

1
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3. In the Save Project window select the necessary folder and
name the file (2). Press Save (3). The window will close.

2
3

4. Open Select video device window using command Tools > Video
device in main menu.
Using the drop-down lists choose the video device that will
broadcast the titles and video. Press OK (4). The window will
close.

4

5. Open Layers window using command Edit > Properties in main
menu.

5

21

In the Layers window compile a list of layers – title projects
that will be used to create title page templates.
To add a layer to the list, complete the following:
1. Press Add... (5).
2. In the opened Open Title Project window select the title
project and press Open (6). The window will close.

6

3. The selected title project will be listed in the Layer
window.
The order of the projects in the list is not important.

7

When you have finished compiling the list, press OK (7). The
window will close.
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6. The main window of the program will change. It will now
contain the following windows (for a description of the
window, see the «Program Interface» section):
●● Layer (1), in which each layer will be displayed as a
separate tab (1a, 1b, 1c). The names of the tabs are the
same as their title projects;
●● Playback (2);
●● Playback movie information (3);
●● Template data sources (4).

2
1

1a

1b

1c

3

4

2. Choosing data sources
7. Open Edit > Data Sources... (1).

1
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8. The Data sources window, designed to manage data sources
used in the current project, will open.

Data sources are added one by one.
9. To add a CSV file as a source to the list, complete the
following:
1. Press Add CSV file (2).
2

2. The Add CSV source window will open.
3

4

3. In the Name field (3) set how the data source (CSV file)
will be shown in the dialog windows when working with the
project.
4. Press

(4).

24

5. In the opened Open CSV File window select the necessary
file and press Open (5). The window will close.

5

6. In the Add CSV source window the data from the selected
file will display in the preview field (6). As the configuration
of the source is not finished, the data may be displayed
incorrectly.

7
8

6

7. Using the Encoding drop-down list (7) choose the encoding
used in the CSV file.
8. In the Field delimiter (8) choose the dividers used in the file
to divide between data of different cells (columns).
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To learn what dividers are used in the file, simply open it in
any text editor, for example, Notepad, and look (9).
9

In the CSV file used in our example the semicolon is used to
divide columns. After choosing the correct divider, the data
from the CSV file will be displayed as a table (10).

10

11

9. Press OK (11). The window will close.
In the Data sources window the added file will be shown in
the sources list (12).

12
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10. To add a data source of the Directory type, complete the
following:
1. In the Data sources window press Add directory (1).

1

2. The Add directory source window will open.
2
3

3. In the Name field (2) set how the data source will be
shown in the dialog windows when working with the project.
4. Press
(3). In the opened Folder overview window select
the folder that contains the task files for the title objects/
elements. Press OK (4). The window will close.

4

5. The path to the selected folder will be displayed in the Add
directory source window in the Directory field (5).
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5
6
7

6. In the Filter field (6) set the file filter. The filter contains
file masks and is used so that only the files of the necessary
type (with the set extensions) are displayed from the
selected folder.
File mask format: *.file_name_extension.
Example: *.txt.
If the *.* filter is set then all of the files contained within the
folder will be available.
7. Press OK (7). The window will close.
The added directory will be displayed in the data source list
(8) in the Data sources window.

8

11. To delete a data source from the list, complete the following:
1. Select the source in the list by clicking on it.
2. Press Remove (9).

9

10

12. When the list of data sources is compiled, press OK (10). The
window will close.
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3. Adding a template
88

Important: The creation of a template is done after layer and all necessary
data sources have been added to the project.

13. In the main window in the Layer window, select the needed
layer (tab). To do this click on the tab name (1).

1

The name of the selected layer will be shown in the Layer
window heading (2); the heading of the active layer tab will
be displayed in black text (3).

2

4

3
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14. Add a new template. To do this press
(4) on the toolbar
in the Layer window.
The Create new template window will open.

5
6

15. In the Name field (5) set the name of the template – an
arbitrary set of symbols. Press OK (6). The window will
close.
16. A new blank template (7) will appear in the tab with the set
name (8).

7

8

The template is shown as a black rectangle.
A blue border around the template signifies that the
template is currently selected for work (editing, creating a
page with titles, etc.).
If you click on an empty area of the Layer window the border
will disappear (9).
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10

9

Several buttons on the toolbar of the Layer window will
become unavailable (10).
The template must be configured.

4. Configuring a template
17. To open the editing window for the template, complete one
of the following:
●● double-click the template;
●● select the template by clicking on it and press
(11), located on the toolbar of the Layer window.

11
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18. The Template properties window will open.

1

2

3

4

The window contains the following elements:
●● table (1) – to display the list of title objects selected by
the user to be used in the template;
●● Тitle Objects... button (2) – to open the dialog to select
title objects;
●● Start/Stop Conditions window (3) – to configure the
conditions of starting and ending the broadcast of title
objects. The window will show the settings for the
object selected in the table (1);
●● Task window (4) – to configure the tasks of the title
elements/objects, i.e. to connect the title elements/
objects and their data sources. The window will show
the properties for the object selected in the table (1).
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19. To create/change a list of title objects, press Title objects… (2).
The Select title objects window will open.
5

8

9

6

7

10
11

The window contains the following elements:
●● Title Objects (5) window that contains:
●● a table with a list of all the title elements (6) contained
within the title project the layer is based on;
●● a field (7) with information on types of task files
for the title object selected in the table (6);
●● Title Elements (8) window that contains:
●● a table (9) with a list of the title elements
contained within the title object selected in the
table (6). You select any object by left-clicking on
its name. If no object is selected in the table of the
Title Objects window then the list of title elements
will be empty;
●● a field (10) with information on types of task files
for the title element selected in the table (9);
●● a window (11) for a schematic display (12) of the title
elements contained within the selected title object in
the table (6).

12
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20. In the Title Objects window select the objects to be used in the
template. To do this, flag the necessary objects (13).
21. Press OK (14) – the Select title objects window will close.

13

14

1

The table in the Template properties window will show the
following information:
●● in the Title Object column (1) – the name of the title
objects, selected for use in the template;
2

3

4
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●● in the Start (2) and Stop (3) columns – the conditions of
starting and ending the broadcast of the title objects.
The conditions of the start/stop are configured by the user in
the Start/Stop Condition window (4) (for more information see
below).
The conditions of ending can only be set for those title
objects that contain title elements with looped tasks.
If the conditions of the start/end were not configured then
the table will show the default conditions: the shift from the
start of the template – 0.
22. If necessary, set the conditions of the start and end of the
object broadcast. To do this, complete the following:
1. Select the title object by left-clicking on its name (5) in
the table of objects.

5

2. In the Start/Stop Condition window set the conditions for the
start of the object broadcast by using the Start element group
(6) and the conditions for the end of the object broadcast by
using the Stop element group (10):
●● in the Type drop-down list (7) select the action, relative
to which the start/end of the object broadcast should
happen.
In the Stop element group the Endless type means that
the object will be broadcast until the entire title page
has stopped broadcasting;
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9
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8
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●● if in the Type list the Relative to object start or Relative to
object stop option was selected, then in the Object dropdown list (8) select the name of the object;
●● in the Offset field (9) set the interval (in seconds)
between the action selected in the Type list and the
start/stop time of the object broadcast.
3. When you’ve finished configuring the start/stop
conditions, press Apply (11).
23. Configure the tasks for the objects that contain elements
into which data from sources needs to be substituted.
The configuration of tasks is done in the Task window (1).

1
2
3
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The object can have a simple or complex task set:
●● select Complex task (2) if task files for title object (files
with the SLTitleTsk extensions) will be used;
●● select Simple task (3) if task files for single title
elements contained within the title object will be used.
To configure a complex task, complete the following:
1. Select an object by left-clicking on it (1).

1

2
3
4

5

2. In the Task window select the Complex task switch (2).
3. In the Data source drop-down list (3) select the name of the
data source.
4. If a file folder is used as a data source, then in the Column
field (4) no configurations need to be made – the field will
automatically display the word File.
5. Press Apply (5).
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To configure a simple task, complete the following:
1. Select an object by left-clicking on it (1).

1

2
3
4

2. In the Task window select the Simple Task switch (2).
3. In the Simple task group table the list of title elements
contained within the object will appear. Select an element in
the table to edit by left-clicking on its name (3).
4. Press Modify (4) – the Select task window will appear.

5
6
7

5. In the Data source list (5) set the name of the data source.
6. If a CSV file is selected as a data source, then in the Column field (6) select the heading of the column, the data from
which needs to be used.
If a file folder is used as a data source, then in the Column
field no configurations need to be made – the field will
automatically display the word File.
7. Press OK (7). The Select task window will close.
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8. Information on the data source settings will appear in
the line of the corresponding element in the table of the Task
window (8).

8

9
10

9. Configure all the tasks for the necessary elements of the
title object. When finished, press Apply (9).
24. Configure the tasks of the necessary title objects.
25. After finishing the configuration the table properties press
OK (10) – the Template properties window will close.
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26. In the Layer window the template that was edited will
be selected via a blue border. The template will display
rectangles that denote title elements:
●● grey color – elements that do not need a data source;

●● green color (1) – elements that have a data source
configured;

1

3

2
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If the template contains elements that need to have a data
source, then in the main window of the program in the
Template data sources window (2) the tabs with the data (3)
will be displayed. The amount of tabs and their names
correspond to the amount and names of data sources used in
the template properties.
The information displayed in the tabs depends on the type
of the source:
●● CSV file – the contents of the file;
●● file folder – list of files.
27. Create and configure any required templates by repeating
steps 14–25.

5. Creating page groups
28. Open Edit > Pages Groups (1).

1

Pages groups are tabs that will display the contents of the
pages with titles.
The amount of groups and how pages are distributed among
them is set by the user. For example, you can group them by
content or by the templates used.
29. In the opened Pages groups window create the necessary
amount of groups.
2

To create a pages group, complete the following:
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1. Press Add... (2) – the Add group window will open.

3
4

2. In the Name field (3) set the name of the page group – any
arbitrary text.
3. Press OK (4) – the window will close.
4. The Pages groups window list will display the name of the
added group (5).
30. After you’ve finished creating page groups, press OK (6) –
the window will close.

5

6

In the main window the Pages group window (7) will appear
(for a detailed description of the window, see the «Program
Interface» section).
7

42

The window contains tabs, the amount and names of which
correspond to the amount and names of the created page
groups.

6. Creating pages with titles
31. In the Pages group window select the group you wish to add
a page to. Select by left-clicking the name of the needed
tab (1).

2

1

32. In the Layer window select the template to create the page
by left-clicking on it (2).
33. Fill in the template with data. To do this use tabs of the
Template data sources window (3). On each tab left-click the
line with the necessary data (4). The data will automatically
be added to the corresponding elements.
In the Playback window the page with titles will be
displayed (5).
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34. Add the page to the selected group in one of the following
ways:
●● take a snapshot of the image in the Playback window
by pressing
press

(6), then in the Pages group window

(7);

●● in the Pages group window press

(7).

35. In the opened Add page window in the Name field (8) set the
name of the page – any arbitrary text.

8
9

36. Press OK (9) – the window will close.
In the Pages group window the new page with the set name
will appear (10).
If a snapshot of the Playback window was made when the
page was added, then the image of the page will be the
snapshot. Otherwise it will be the moment of the start of the
display of text on the page.
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37. Add the necessary pages to all of the page groups by
repeating steps 30–36.

7. Selecting program work mode
38. If the SLNewsTitler program will be used as both a foreground
(title) and background (video) server, skip to step 39.
If the SLNewsTitler program will be used only as a title
server, then make sure that the display of video is turned off
in its settings. To do this, complete the following:
1. In the main program window open the Edit menu.

1

2. Make sure that the Enable video playback line (1) is not
flagged.
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3. If the Enable video playback line is flagged (2), unflag it by
left-clicking on it.

2

The project is complete. Skip to step 50 (p. «11. Saving the
project»).
39. If the SLNewsTitler program will be used as both a
foreground (title) and background (video) server, continue on
with configuring its settings by following the steps below.
40. Turn on the mode that allows working with video. To do
this, complete the following:
1. In the main program window open the Edit menu.

1

2. Make sure that the Enable video playback line (1) is flagged.
If the Enable video playback line is not flagged, flag it by leftclicking on it (2).

2

3. Save the project using File > Save.
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8. Configuring video inputs
41. If it is necessary to broadcast video from a video input,
configure the video inputs:
1. Open Edit > Video inputs (1).

1

2. In the opened Video inputs settings window select the video
input by flagging it (2).

2
3

3. Select the input line to which the source of the input
signal is connected to. To do this press the active button (3)
and in the pop-up menu select the line (4).

4

5

4. Close the Video input settings window by pressing OK (5).
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5. In the Video input settings window in the corresponding
drop-down list (6) select the input audio line.

6

7

6. Configure all necessary video inputs by repeating steps
2–5.
7. Once you’ve finished configuring, press OK (7) – the
window will close.
42. Check if the video inputs are correctly configured. To do this:
1. In the main program window press the Show Live
button (8) on the Playback panel.
2. In the drop-down list select the necessary video input (9).
8

9

3. The preview window (on the TV screen or in the
FDPreview window) the video from the selected input
should appear.
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9. Adding playlist
A playlist is an ordered list of video data (video files, video from
board inputs). One project can use several playlists.
43. Open Edit > Playlists (1).

1

44. The Playlists window will open. It is designed to edit the
playlist list.
2

Playlists are added one by one:
1. Press Add (2) – the Add Playlist window will open.

3
4

2. In the Name field (3) set the playlist name – any arbitrary
text.
3. Press OK (4) – the window will close.
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4. In the Playlists window list the name of the added playlist
will be displayed (5).

5

6

45. Once finished adding playlists, press OK (6) – the window
will close.
The main program window in the Pages group window will
change:
●● new tabs will appear, the amount and names of which
will correspond to the amount and names of the
playlists added on the previous step (7);
●● when selecting a playlist tab, the heading of the
Pages group window will change to Playlist (8), and the
toolbar will change (9) (for a descriptions of the Playlist
window, see the «Program Interface» section).
8

9

7
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10. Compiling a playlist
46. Switch to the tab of the necessary playlist. To do this,
simply left-click on the tab name in the Pages group/Playlist
window.
47. On the selected tab compile a playlist – an ordered list of
video data.
The list can contain the names of video files and commands
to start broadcasting video from one of the configured video
inputs.

2

1

To add a video file to the playlist, complete the following:
1. Left-click on the Add video file
button (2) on the
Playlist window toolbarl – the Add Video Files window will
open.

3
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2. In the Add Video Files window select the video file and
press Open (3) – the window will close.
3. In the Playlist window the name of the added file will be
displayed last in the File list (4).

4

To add a command to start broadcasting video from one of the
configured video inputs to the playlist, complete the following:
1. Left-click on the

(5) icon, located near the

Add live button

.
2. In the opened window set the name of the video input (6).
5

6

3. In the Playlist window the identification of the selected
input will appear last in the File list (7).

7

48. Configure the list if necessary. Select an element in the list
by left-clicking on and press one of the buttons (8):
– to delete the selected element from the list;
– to move it one position up;
– to move it one position down.
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8

49. Create all necessary playlists that need to be added to the
project. To do this repeat steps 46–48.
The project is complete. Save the project.

11. Saving the project
50. Save the project by using File > Save (1).

1
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Important: After creating and saving a project it is not allowed to change
the names and placement of the files/folder used (for title
projects, files, and data folder, video files, etc.).
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Working with the program during live broadcast
1. Controlling the display of pages with titles
1.1. Broadcasting requirements
The user starts the display of the page with titles using
the

button, located on the toolbar of one of the windows:
●● Page group, where the corresponding group of
prepared pages is located (see «2. Operatively adding
information to data sources» section below);
●● Preview, if the page is being created during broadcast
(see «3. Operative creation and start of pages with
titles» section below).

It is possible to broadcast several title pages at once. The
following conditions need to be met:
●● the pages are located in one page group;
●● the pages are created based on templates located in
different layers (i.e. based on different title projects).
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Important: It is impossible to broadcast multiple title pages created based
on templates that belong to the same layer.

The user can stop the display of the pages by using
the
button on the toolbar of the corresponding panel, or it
will stop automatically after the time of display of all of the title
objects located on the page has run out.
The user can also assign hotkeys to starting and stopping the
display of a page. To open the hotkey designation window, open
Service > Hotkeys.

1.2. Starting broadcst
General procedure:
1. Open the necessary page group by clicking on its heading in
the Pages group window (1).
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1

2. To start the broadcast of one page, double-click on the
image/name of the page (2) or select the page by clicking on
it once and pressing

(3).

3

2

3. To start broadcasting another page simultaneously select it
and press

(3), or double-click the page image/name (4).
3

4

5

Note:

The requirements for simultaneous broadcast of several pages are
stated above in paragraph 1.1.
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4. A red border (5) will appear around the images of the pages
currently being broadcast. The Broadcast status in the page
group will appear as Running (6).

6

1.3. Stopping broadcast via user command
General procedure:
1. Open the pages group of the pages being broadcast.
2. Select the title pages that need to be stopped (1).
2

1

3. Press

(2) on the toolbar.
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2. Operatively adding information to data sources
During broadcast the user can add information to data sources
that are used in an open project: new lines in a CSV file and
new task files for title elements in the directory. This can be
necessary if a new person appears on screen.
Note:

New information can be immediately be broadcast (see next section).
You can add data to a CSV file in the SLNewsTitler program as well
as any text editor that supports the format (Notepad, MS Excel, etc.)

2.1. Viewing the contents of data sources for a template
To view the current data for a specific template, complete the
following:
1. In the Layer window left-click the tab with the necessary
layer (1).
2. In the opened tab click the necessary template. The selected
template will be be marked by a blue border (2).

3

2

1

4

3. The Template data sources window (3) will display tabs with
the current data sources for the selected template. To select
a data source, click the corresponding tab.
4. To refresh the data source if something has changed (for
example, if a task file has been added to the directory), press
Refresh

(4).
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2.2. Adding data to a CSV file
To add new data to a CSV file data source in the SLNewsTitler
program, complete the following:
1. In the Template data sources window select the tab with data
from the CSV file (1).
1
2

2. Press
(2).
The Add new row window will open.
The window will display text fields for data input, the
headings of which correspond to the headings of the columns
in the CSV file (3).

3

4

3. Input the data into the text fields. You do not need to fill all
of the fields.
4. Press OK (4) – the Add new row window will close.
5. The opened tab will display a new line with data (5).

5

6

If the CSV files are edited in a different program, to renew the
data source complete the following:
1. In the editor save the edited file.
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2. In the Template data sources window make sure that the tab
corresponding to the edited CSV file is opened and press

(6).

2.2. Adding data to a Directory type data source
General procedure:
1. Create a new task file and save it in the folder that
corresponds to the corresponding Directory data source (1).

1

2. In the SLNewsTitler program in the Template data sources
window select the tab with data from Directory type data
sources (2).

2
3

3. Press

(3) – the list of files will be refreshed.
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3. Operative creation and start of pages with titles
During live broadcast it might be necessary to display titles
with data that was not contained in the title pages created
beforehand, for example, information on a person who just
appeared on screen.

3.1. General procedure
1. In the Layer window go to the necessary layer (1) and select a
template to create a page by left-clicking on it (2).

3
2

1

2. In the Template data sources window tabs with data from the
selected template will appear (3).
3. Select data to insert into the template in each tab. Select
data by left-clicking the lines with data.
4. The generated title page will display in the Playback
window (4).
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5

4

5. To start the page broadcast press
toolbarl of the Playback window.

(5), located on the

3.2. Specifics of starting page broadcast from the Playback window
1

Starting a page from the Playback window always stops the
broadcast of the page started from the Playback window
previously.

2. Starting a page from the Playback window always stops the
broadcast of the page started from the Pages group window
if the pages are created based on templates from the same
layer (title project).
3. Starting a page from the Playback window does not stop the
broadcast of pages started from the Pages group window if
the pages are created based on templates from different
layers (title projects).
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4. Managing background video
4.1. Start order of playlist playback
1. In the Playlist (Pages group) window select the tab with the
necessary playlist by left-clicking on its heading (1).
3

2

1

2. Select the playlist element from which the broadcast should
start by left-clicking on it (2).
3. Press

(3) to start video broadcast.

4.2. Specifics of playlist playback
Playlist elements are played in their playlist order.
If the playlist element is a command to start broadcast of video
from a board input then the start of the next playlist is done by
the user’s command. To do this the user must select the next
playlist element to be broadcast, left-click on it, and press

.
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Timer Display
1. General information
Preparing to display timers is done in two stages:
●● in the FDTitleDesigner program a title project is
created and part of the settings for the timer(s) are
configured;
●● in the SLNewsTitler program the timers are fully
configured and the user controls their functions: start,
stop, and reset.
A timer can be a master or slave. If a timer is a slave, it
synchronizes its time count with the master timer. If a master
timer is stopped, all of its slave timers automatically stop as
well.
Time count borders are set by the user.
A timer can also be used to count down. The direction of the
time count is determined automatically and depends on the
values of the start time and the end time of the timer, set by the
user:
●● if the start time value is less than the end time value,
then the timer counts normally;
●● if the start time value is greater than the end time
value, then the timer counts down.
You can display several timers at once.

2. Preliminary preparation
A title project needs to be created in the FDTitleDesigner
program. To create a timer a Timer type title element (1) needs
to be added to the title project.

1

88

Important: The Timer type title element becomes available in the

FDTitleDesigner program only after the SLNewsTitler is
installed to the computer.
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One title project can contain multiple timers.

„„

Tip: It is recommended to name all title objects and elements

sensibly, as their names will also be used in the SLNewsTitler
when configuring timers.
In the FDTitleDesigner program the following timer settings
are set:
●● Alignment and Stretch;
●● Specific (Time format);
●● Text Formatting (Styles file).
When starting a preview of a title project in the
FDTitleDesigner program all timers count normally starting
from 0.
You can set the direction of the timer as well as the maximum
and minimum time value of the timer in the SLNewsTitler
program.

3. Configuration
3.1. Configuring timer settings
In the Timers window a record (timer) must be created for each
timer that will be displayed in titles during broadcast.
1. Open View > Timers Window (1).

1

2. In the main window the Timers window will appear (2).
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3

3

3. Add a timer:
1. In the Timers window press
Add master/slave timer (3).
2. A record of a new timer will appear in the Timers
window (4).

4

3. Left-click the line with the new timer – the window the
default timer values will display (5).

5
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If necessary, change the values of the timer parameters:
●● Name – name of the timer, an arbitrary set of symbols.
This name will be used when selecting a data source
for the selected timer;
●● Parent – set the type of timer – Master or Slave:
●● if the timer is a Master, set the value as
<No Parent>;
●● if the timer is a Slave, set the value to its Master
timer’s name. A Slave timer can only be created
after the Master timer has been created;
●● Start – value of the timer when it is reset;
●● Current – current time, as well as the time the timer
starts from when it is started. When configuring the
timer for the first time, we recommend setting this as
the same value as Start;
●● Stop – stop time of the timer. When the timer reaches
this time, it will stop;
●● AutoReset – what the timer will do once it reaches stop
time:
●● True – the timer will reset to Start value;
●● False – the timer will not reset and will retain its
final time value;
●● HideOnStop – what the timer will do once it reaches
stop time:
●● True – the timer will stop being displayed;
●● False – the timer will continue being displayed.
4. Add the necessary amount of timers and configure them.

3.2. Adding created timers to the data source list
5. In the main window of the program open Edit > Data Sources... (1).

1
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6. The Data sources window will open.

2

7. Press Add timer (2) – the Add timer source window will open.
3
4
5

6

8. In the Name field (3) set the timer name.
9. In the Timer drop-down list (4) select the needed timer in a
list of all of the timers added on step «3.1. Configuring timer
settings».
10. Close the Add timer sources window and save all changes
by pressing OK (5). To close the window without saving
changes, press Cancel (6).
11. Information on the newly added source will be displayed in
the Data sources window (7).

7
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12. Add data sources for all of the created timers by repeating
steps 6–10.

8

13. Close the Data sources window and save all changes by
pressing OK (8).

3.3. Creating a layer for page templates with timers
14. In the main program window open Edit > Properties... (1).

1

15. The Layer window will open. In the Layer window press
Add (2).
2
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16. In the opened window select the prepared title project with
timers and press Open (3).

3

17. In the Layer window the name of the added layer (4) will
appear. The name of the layer will be the same as the name
of the title project.

4

5

18. Close the Layer window and save all changes by pressing
OK (5).
19. If no layers were added to the project beforehand, the layer
window will appear in the main program window. The name
of the added layer will appear in the heading of the new
window (6).
If layers were previously added to the project, then a tab
will appear in the Layer window with the name of the added
layer.
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3.4. Creating a page template with timers
20. In the Layer window select the tab with the layer, prepared
for page templates with timers.
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Important: All timers that might be displayed simultaneously should be
located in one template.

21. To add a new template press
Layer window.

(1) on the toolbar of the

1

22. The Create new template window will open.

2
3

23. In the Name field (2) set the template name – an arbitrary
set of symbols.
24. Press OK (3) – the Create new template window will close and
the template settings window will automatically open.
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25. In the Template properties window press Title objects…
button (4) – the Select title objects window will open.

5

6

For a description of the window see the «Working with the
program» section, paragraph «Creating a new project»,
subparagraph «4. Configuring a template».
26. In the Title Objects window flag the names of the title objects
that need to be added to the template (5).
27. Press OK (6) – the Select title objects window will close.
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The Template properties window table will display the
following information:
●● in the Title object (1) column – the names of the title
objects, selected to be used in the template;
1

2

3

●● in the Start (2) and Stop (3) columns – the conditions of
the start and end of the title object broadcast, set by
default.
28. Configure the start and end broadcast conditions. To do this,
complete this following:
1. Select the title object by left-clicking on its name in the
object list (4).

4

5

6

7
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2. In the Start/Stop Conditions window set the conditions for
the start of the object broadcast by using the Start element
group (5) and the conditions for the end of the object
broadcast by using the Stop element group (6):
●● in the Type drop-down list (6) select the action, relative
to which the start/end of the object broadcast should
happen.
In the Stop element group the Endless type means that
the object will be broadcast until the entire title page
has stopped broadcasting;
●● if in the Type list the Relative to object start or Relative to
object stop option was selected, then in the Object dropdown list select the name of the object;
●● in the Shift field set the interval (in seconds) between
the action selected in the Type list and the start/stop
time of the object broadcast.
3. When you’ve finished configuring the start/stop
conditions, press Apply (7).
29. Configure the tasks for the Timer type title elements.
Complete the following:
1. In the table with the list of the title objects, select the title
object that contains the timer.
2. In the Task window select Simple task (1).

1
2

3
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3. A list of title elements, contained in the object, will
appear in the Simple task group table. Select the Timer
element type in the list by left-clicking on it (2).
4. Press Modify (3) – the Select task window will open.

4

5

5. In the Data source (4) list select the name of the timer
source.
6. Press ОK (5). The Select task window will close.
7. Information about the data source for the timer (6) will
appear in the Task window table.

6

7
8

30. Configure the tasks for all necessary title objects. After
you’ve finished, press Apply (7).
31. Once finished configuring template settings press OK (8) –
the Template properties window will close.
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4. Controlling output
1. In the Layer window select the template with the timer by
left-clicking on it (1).

3

4

1

2

2. Tabs with data sources for substitution into the template
will appear in the Template data sources window (2).
Sequentially open each tab and in each tab select a data
source by left-clicking on it.
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Important: If a source is not selected, the data will not be displayed.
3. In the Timers window (3) in the table with a list of timers
flag those timers that need to be displayed when the page
will be broadcast in the Name (4) column.
When flagging a Master timer all of its Slave timers will
automatically become flagged. If necessary, you can unflag
them by left-clicking on them.
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4. After flagging the timers, they will appear in the Playback
window (5).
6

5

7

To start the display of titles with the timer you need to
press Start broadcast selected template
(6) in the Playback
window.
To stop broadcasting a page with titles, press Stop broadcast
of template
.
5. To start the selected timers press Play selected timers
in the Timers window.

(7)

6. To stop one timer, unflag it (8) in the Name column in the
Timers window table. If you stop a master timer, all of its
slave timers will automatically stop. To stop all timers,
press Pause selected timers

(9).
9

8
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Program Interface

Main window
Immediately after opening the program, the main window is
empty.

When creating a new project or opening a previously created
one, windows for management of different project elements will
automatically open.
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When working with a project, the following windows can be
open in the main program window:
●● Layer window (1) – for creating and managing
templates;
●● Playback movie information (2) – to display information
about the video broadcast;
●● Playback (3) – for previewing pages with titles. You can
not preview the full-screen video;
●● Template data sources (4) – the window contains the data
source contents set for the template, selected in the
Layer window. Data from different sources is displayed
in different tabs. Tabs look different for different types
of sources (CSV file and Directory);
●● window for working with page groups and playlists (5).
The heading of the window will change depending on
what is currently open in the window:
●● Pages group – when working with tabs containing
title pages;
●● Playlist – when working with tabs containing
playlists.
Windows open automatically during project configuration. You
can change the size and placement of the windows (see image
below).
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Main menu
The main menu contains the following submenus:
●● File – commands to manage project files;
●● Edit – commands to open settings windows;
●● View – commands to shift and activate working
windows of the project;
●● Tools – commands to select video devices and assign
shortcuts;
●● Help – commands to select the interface language and
to open the information window.

Тable 1.

Main Menu Commands

Name

Purpose

Hotkeys

New...

Open window for creating a new project.

Ctrl+N

Open...

Open project from file.

Ctrl+O

Close

Close current project.

Save

Save current project.

Save as...

Save current project as a new file.

Recent files

Show list of project files, used last. Select one of the
project files.

Exit

Close the program.

File Menu

Ctrl+S

Alt+F4

Edit Menu
Properties...

Open the Layer window to edit the list of layers.

Pages Groups...

Open the Pages group window to edit the list of pages
groups.

Data Sources...

Open the Data sources window to edit the list of data
sources.

Enable video Playback

Allow/unallow the program to work in background
(video) server mode – full screen playback of video files
and video from the board input.

Playlists...

Open the Playlist window to edit the list of playlists.

Video Inputs...

Open the window to edit the list of video inputs.

View Menu – commands to open windows in the main program, closed by the user

when working with the project.
Preview window

Show Playback window.

Timers window

Show Timers window.

Layers

Show selected layer in the Layer window.

Pages Groups

Show selected page group in the Pages group window.
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Name

Purpose

Template Data Sources

Show Template data sources window.

Playlists

Show selected playlist in the Playlist window.

Hotkeys

Tools Menu
Video device...

Show video device selection window.

Keyboard shortcuts...

Show keyboard shortcuts selection window.

Help Menu
About the SLNewsTitler
program

Open window with program information.

Language...

Switch to russian (english) language interface.
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Layer window
The Layer window is for creating and configuring templates of
pages with titles.

1

2

3

The window contains the following control elements:
●● toolbarl (1) with buttons for fast use of commands (see
descriptions on buttons below). The commands affect
the templates of the current tab;
●● tabs (3) – one for each title project used in the
SLNewsTitler. Each tab contains a field (2) that
displays the templates created based on the
corresponding title project. To open a tab, left-click its
heading.

Тable 2.
Button

Toolbarl buttons

Purpose

Add new template.
Delete selected template.
Rename selected template.
Open settings window for selected template.
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Template data sources window
The Template data sources window is for displaying data from
sources, set for substitution into the template selected in the
Layer window.

3

1

2

If a template is not selected in the Layer window then the Template data sources window will be blank.
The window contains tabs – one for each data source set for
the selected template. The heading of the tab is the name (1)
set for its source when it was added to the project. Each project
contains:
●● toolbar (2) with buttons for fast use of commands.
The buttons on the panel depend on the type of source
(CSV file (4) or Directory (6));
●● field (3) to display data from the source:
●● data from the CSV file is displayed as a table (5);

4

5
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●● data from a Directory is displayed as a list of
files (7) from the set folder, the names of which
satisfy the current filter.

6

Тable 3.
Button

7

Toolbar buttons for work with data from CSV file

Purpose

Add new row to table.
Delete selected line from table.
Edit selected line.
Refresh data (same action for a Directory type tab).
Open dialog to export the text data from a table into a CSV file.
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Page group/Playlist window
Page groups and playlists are managed in the same window.
The heading of the window displays the name of the tab opened
in the window and its type: Pages group – for groups of pages
with titles; Playlist – for lists of full screen playback.
The window contains:
●● heading line (1). The line displays the name of the tab
opened in the window and its type – Pages group (2) or
Playlist (3);
2

1

3

4
7
5

6

●● toolbar (4). The list of commands is different for
playlists and page groups (see table below);
●● field for previewing pages with titles/playlist (5);
●● tabs (6) to select pages with titles/playlists.
Information about pages with titles can be displayed in
graphical (7) or textual (8) form.

8
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In graphical form information about the current state of the
table is shown using a colored border:
●● red color (9) – the page is being broadcast;
●● blue color (10) – the page is being previewed.

9

10

Information on the playback status of the playlist is displayed
using a special symbol
(1) that marks the element currently
being broadcast, as well as in the Playback movie information
field (2).

1

2

Тable 4.
Button

Toolbar buttons for work with page groups

Purpose

Start broadcasting selected page.
Stop broadcasting selected page.
Start previewing selected page.
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Button

Purpose

Stop previewing selected page.
Open window to create new page in current group.
Delete selected page from page group.
Rename selected page.
Open settings window for selected page.

Тable 5.
Button

Toolbar buttons for work with playlists
Purpose

Start playlist playback from selected element.
Broadcast first frame. The first frame of the selected element will be broadcast.
Open window to add video files to playback list.
Select a video input in a drop-down list by number. The command Input N is
added to the end of the list.
Delete selected element from the list.
Move selected element one position up.
Move selected element one position down.
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Playback window
The Playback window is for previewing title pages. If necessary,
the broadcast of a page can be started from the Playback
window.
2

1

3

The window contains the following control elements:
●● preview window (1);
●● toolbar (2) with buttons for fast use of commands (see
table below);
●● playback movie information (3).

Тable 6.
Button

Toolbar commands

Purpose

Start broadcasting the previewing page.
Stop broadcasting the page.
Select a video input in a drop-down list by number and start broadcasting the
video from the selected input.
Take a snapshot of the preview window to create a page.
Start previewing page.
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The Playback movie information field is for displaying information
on the video data being broadcast.
The field displays the following:
●● during broadcast of video files:
●● in the Playing item field (1) – the path to the playing
video file;
●● in the Time field (2) – time passed since the start of
broadcast (3) and the entire duration of the video
file (4);
●● the indicator (5) displays information on the
broadcast status in graphical form;

3

4
6

1
2

5

●● during broadcast of video input – in the Playing item
field the name of the input (6) is displayed.

6
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Useful links
Forward T Product Line: Description, Software Delivery, Documentation, Ready
Solutions
http://www.softlab.tv/forward/index.html

Tech Support
e-mail: forward@sl.iae.nsk.su
forward@softlab-nsk.com
forward@softlab.tv

Forums
http://www.softlab-nsk.com/forum (currently available in Russian only)

Documentation for more information:
FDOnAir: Broadcast automation
FDOnAir: Additional Sections
FDTitle Designer: Title Project Editor
FDPreview: Program for Previewing of Audio and Video on Boards Inputs/Outputs

Translation from
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