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1 Introduction
Thank you for purchasing our product!
Your system is completely configured and ready for use. This document provides full information on
the functionality of this set of tools for television production.
The current revision of the document (1.63) corresponds with the VS HotActionsLite 1.63 software.
The HotActionsLite application is intended to perform the working shooting in the process of
television production. All the materials required for shooting (a project containing the necessary video
and audio materials, three-dimensional graphics design elements, data controls and virtual design
objects controls) are prepared in the HotActions application.
It is necessary to properly connect video and audio equipment and adjust the settings of the input and
output video and audio before shooting. For more detailed information about the necessary hardware
connections, see sections 2.1 and 8 (appendix) of this document. The audio and video settings are
covered in individual documents. The parameters of the output video, such as television standard
(PAL or NTSC) and the output signal type, should be correctly adjusted by each user. If not required
to change the studio operation mode, there is usually no need to adjust the output video parameters
again. The adjustment of the input video parameters is usually required after changes of the external
equipment (video cameras) configuration. The chroma keying (rear projection) parameters may need
to be adjusted, for example, if the illumination in the shooting stage has changed. An example of
configuring the input and output video is given in section 2.3.
Any necessary action or adjusting parameters can be executed directly during the shooting either
automatically according to the script or interactively under the operator‟s control.
Section 2 briefly describes a typical procedure of adjusting the system; it gives a short compendium
and information necessary for starting the system and achieving first results.
The document describing the details of assemblage and configuration adjustment is included in the
installation package when necessary.
The next sections include the reference guides for all the software components of the system which
fully describe the interfaces and functional features of the current Focus Lite virtual studio version.
Some typical problems and their solutions are discussed in section 6. We also recommend to regularly
visit our Web and FTP sites (see section 6.4) where the latest versions of the software and
documentation, new information, users‟ questions and responses are available for your use.
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2 Checking the Studio Performance
This section describes how to check the Focus Lite virtual studio operability and gives the essential
principles of work with the НotActionsLite application. The next sections describe the application in
detail. The video and audio settings are described in separate documents.

2.1 Switching the Studio Components and Connecting External
Equipment
First of all, assemble the studio components in their correct positions. Connect the corresponding
switching devices to all the input/output FD300 boards,
whose connectors are located on the studio unit back panel
to switch the signals. These may be special cable sets or
Breakout Boxes described in Section 8.
Depending on the configuration, the studio unit may have
one or more input/output FD300 boards installed, but usually
one of them only is used to output the resultant video and
audio.
In studios that work with HD video signals, an FD300 board
is only necessary to work with audio signals (adjusting
parameters). The studio resultant video image is output in
such configurations through the hardware module DVM62
(Digital Virtual Machine). In this case, connect the video
card DVI connector with the module DVI connector, and when the computer is on, adjust the second
video adapter (NVIDIA GeForce) operation. Adjusting such configurations is discussed in Section 7.
When working with analog video signals (component YUV or RGB, S-Video, or composite), video
and audio signals are supplied from the FD300 board through the cable set or breakout box (see
Section 8, Appendix) to a TV monitor to output the resultant image. The input video sources such as
video cameras and video recorders are also connected to the breakout boxes or cables.
For a studio configured to work with digital signals (SDI), the studio unit back panel must also have
connectors to switch such signals.
The computer monitor, keyboard and mouse are connected as usual.
After making sure the connections are correct, you can switch on the computer.

2.2

Checking the VGA Settings and Launching HotActionsLite

To work with 3D graphics, the virtual studio must have the anisotropic filtering and graphics card
antialiasing modes adjusted.
Only the NVIDIA GeForce graphics video adapter included in the studio configuration provides the
studio correct operation. To check the video card settings, open the NVIDIA Control Panel dialog box
using the Start menu: Start > Settings > Control Panel > NVIDIA Control Panel.
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Figure 1. Setting the video card modes for working with 3D graphics.

Select 4x in the Anisotropic filtering drop-down list in the Manage 3D Settings page of the 3D
Settings group. Select 16x in the Antialiasing – Setting drop-down list. To make the mode
available, previously select Override any application setting in the Antialiasing – Mode dropdown list.
After th the NVIDIA settings are verified, proceed to setting video signals in the Virtal Studio.

2.3 Video Settings
The video settings are discussed in detail in a special document on setting video and audio (Video and
Sound Settings). Only the basic adjustment steps are discussed here. When working in the Studio with
analog or digital (SDI) video signals, previously determine some parameters of theirs in the FD300
Configuration application (Figure 2).The application is discussed in FD300 configuration. User’s
Guide.
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Figure 2. Presetting video signal parameters in the FDConfiguration application.

For all the FD300 boards indicated under Boards'Indexes as Fwd 1, Fwd2 and so on, select a TV
standard for the operational signals supplied to the board (PAL, NTSC, or other) from the
TV Standard drop-down list on the Format tab.
Click the Advanced… button (Figure 2). The Advanced Settings dialog box opens (Figure 3). For
each board with connected video sources, enable the A/V Capture Filter option under Use Direct
Show filters. Since operation with video signals in the Virtual Studio is performed through Direct
Show filters, it is necessary that their operation be enabled in the settings of the FD300 boards to
which video signals are supplied.

Figure 3. Enabling work with video signals on the FD300 board through Direct Show filters.

To output the video signal of the resultant image, the FD300 board having the largest logical index L
is used in the Studio. Usually it matches the system index S. For this board, select an analog video
signal type from the Analog Video Output drop-down list on the Output tab. Usually, it is
Y/C+CVBS (S-Video signal type) or YUV+CVBS (component). The default is ColorBar+CVBS:
color-bar test pattern output.
The TV format of the Studio output video signal is determined by the output board format selected
from the TV Standard drop-down list on the Format tab.
7

Figure 4. Setting the Studio output video signal in the FDConfiguration application.

If the Studio video signal output board is to operate as the Genlock option (synchronization of the
output signal to the external source), select the board line to which the synchronization signal is
supplied from the Source drop-down list under Genlock Internal Video: Line A or Line B. The
indices of the video signals connected to the board are determined in the Input drop-down list on the
corresponding tabs Line A or Line B of the FDConfiguration application.
Absent the requirement of synchronization of the output video signal to the external video source,
select for the output board the mode of its internal synchronization Master from the Source dropdown list under Genlock Internal Video.
After presetting parameters of the FD300 boards for working with video signals, proceed to mastering
the main application of the Virtual Studio - HotActionsLite. To launch the application, use the Start
menu (Figure 5) or double-click the HotActionsLite
icon on the Windows desktop.
Before launching the application in an HD studio (Section 7), plug the HASP dongle into the computer
USB port (to have support for the HASP dongle in the operating system, use the HASPUserSetup.exe
installer). Otherwise a warning message to have the protection device plugged in is displayed when
launching the application.
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Figure 5. Launching the main application of the Virtual Studio.

The HotActionsLite application is represented by the same-name window to control the studio and the
Render Output window. At the application start-up the Render Output window is opened by default
on the monitor connected to the device intended for the image output (FD300 board or DVM62
converter) in full-screen mode. You can also work with the application in the window mode described
in detail in section 4.
Setting the input video signals in the HotActionsLite application is performed on the Input Video
Options tab of the Video Configure dialog box. To open the dialog box, click the Live Video
Configure

button of the Live Action toolbar (Section 3.2.2), or use the Video Configure...
command from the Tools menu, or press F9 on the keyboard.
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Figure 6. Dialog box for setting input video signals in the HotActionsLite application.

From the Stream drop-down list under Input Source, select a video stream (LIVE_1, LIVE_2, and
so on) to show the video signal connected to the video source input board. Assign an input device –
one of the board channels (FD300 or Aja XENA) from the Device drop-down list to the selected video
stream. Since each board has two input channels, there are two options in the drop-down list for each
board: SLTM DShow Video Capture board 1 and SLTM DShow Video Line B Capture board 1 – the
FD300 input channels, or AJA Capture Filter board 0 cannel 1 and AJA Capture Filter board 0 cannel
2 for Aja XENA.

Figure 7. Drop-down list of the connected video signal input devices.

There are only the input channels for the Aja XENA boards (HD stream input devices) in the dropdown list.
When an input channel for the video stream is selected, you can change the field order for the video
signal (when necessary) in the Fields drop-down list. Or you can change the video signal. To do so,
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click the Options button. The Properties dialog box opens. Select another video signal index from
the Input drop-down list on the Input tab.
Use the
area to set the frame cropping values when displaying – the nondisplayed offsets: top,
bottom, left and right offsets respectively. The Feather parameter value determines the smoothness of
transition from nondisplayed parts of the frame to displayed. The Corners parameter value determines
the corner cropping. Clicking Auto enables the cropping offsets self-adjustment. Checking
enables the area settings; unchecking the checkbox disables all the frame croppings.
To set the input video signal chroma key (rear projection) parameters, check the
check box. When the background quality is good, lighting being enough, automatically setting this
area parameters usually gives good results.
The dialog box parameters are described in detail in Video and Sound Settings.
Setting the resultant image video signal output is performed in the Render Options dialog box
(Figure 8). The dialog box is described in detail in Section 4.3. To open the dialog box, press F11 or
select the Render command in the Options menu of the Render Output window. When rendering
video image by the FD300 board, select from the Output Device drop-down list under General the
FD300 board with the number matching the logical index L specified in the FDConfiguration
application (Figure 4).
When working with HD video signals (Section 7), select the output Display2: DVM62 (as the video
signal output device) from the Output Device drop-down list in the Render Options dialog box.

Figure 8. The Studio resultant video image output settings dialog box.

2.4 Audio Settings
External audio equipment is connected to the FD300 board connectors via a special cable set
(Section 8.1) or breakout box (Sections 8.2, 8.3, 8.4). All the audio played in HotActionsLite is output
via the sound card which is set in the operating system as default. To combine the audio stream with
audio from a microphone or other sources connected to the switching devices, select one of the FD300
audio channels as the output device in the operating system settings ( Start -> Settings -> Control
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Panel -> Sounds and Audio Devices -> Audio, Default device drop-down list under Sound
playback). Usually it is an output device of the output board with the largest logical index L in the
FD300 Configuration application (Figure 4). The Disable audio devices option on the Sound tab in

the FDConfiguration application must be previously unchecked.

Figure 9. The tab for setting sound on the output board in the FDConfiguration application.

The required mode of sound mixing in the Studio (the HotActionsLite application) is set in the
Sound Configure dialog box. To open the dialog box, click
, or use the Sound Configure
command from the Tools… menu (see also Sound Configure. User’s Guide).

2.5

Working with Sample Projects

Having the input and output video settings properly adjusted, you can proceed to further examination
of the opportunities given by virtual studio.
The Project drop-down list of the Project toolbar (Figure 10) is intended to select a project to be
loaded from the list of frequently used (last opened) ones. The
button corresponding to the
Open Project… command of the File menu in the application main window (section 3.2.3) starts the
Open Project… dialog, from which any project can be loaded as well.

Figure 10. The Project toolbar

Let us select the Sport project to work with (the Sport.vsz file). The project is usually located in the
D:\Focus\VS_Samples_Lite\VS_Basic folder along with the other sample projects supplied in the
virtual studio package.
The arrangement of windows corresponding to the documents included in a project is restored in the
main application window when loading the project. Work with projects is desribed in detail in section
3.1.1.
The information of an opened scene: the number of mesh objects, polygons, textures, and the video
adapter memory value occupied by them is displayed in the Debug Output window (section 3.6) when
loading a project.
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The window with the title Sport.hot is used to directly control the scene. It is a Hotset containing the
HotBars – floating toolbars.
Now you can check the Focus virtual studio operability. If the previous operations are performed
correctly, the Render Output window (TV monitor) displays a scene (though, a project contains only
one scene as usual).
The Play Sport button on a floating toolbar of the Hotset starts the scene animation playback. The
names for the buttons of other scenes performing similar actions are usually formed in the same way:
“Play + scene name”. The buttons of the “CAMERAS” floating toolbar of the scene are intended to
control the virtual cameras.
The

button of the application main window exits the application.

After a sample file has been loaded and played back for the first time, you can explore the system
functionality in detail, reading the next sections.
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3 HotActionsLite Application
The HotActionsLite application included in the Focus virtual studio software package presents an
ergonomic environment for interactively controlling 3D graphics scenery (3D scene) along with the
video streams in real-time operating mode. The application is presented by the main window, which
provides the media for controlling the virtual studio, and the Render Output window displaying the
created video images.
As was mentioned in the Introduction, to work in HotActionsLite it is necessary:
1. to create a project including all the required video and audio materials, design elements (threedimensional graphics design), given and virtual design objects controls. Such a project is created
in the HotActions application.
2. to adjust correctly the input and output video and audio signals.

3.1 Basic Notions of HotActionsLite
To present the general idea of how to work with the application, we shall describe the basic means of
work with it: Project, Hotset, Hotbar, Theme.

3.1.1 What is a Project?
A Project presents the main means to organize the work in the HotActionsLite.
A project file (*.vsz) contains all the documents necessary for work. It also contains information about
the files state (opened, hidden or closed), windows and toolbars arrangement and other settings.
The HotActionsLite application allows you to load only one project at the same time. At attempt to
load another project, all the windows of the previous one are closed. If a new Theme file (*.vst, see
section 3.4.1) was created when working with a project, the project displays a confirmation request to
save the file in the project when closing the project.

3.1.2 What are a Hotbar and a Hotset?
Hotbars are button panels gathered on a general panel (Hotset) and directly used as a basic interface to
control the scene.

Figure 11. Hotbar and Hotset – basic tools to work in HotActionsLite.

A Hotset is a set of Hotbars. A Hotset is handy in that to hide, show or move all the Hotbars in it
simultaneously.
Each button of a Hotbar executes a corresponding Action or a sequence of actions. The order of
actions is specified when creating a project in the HotActions application.
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3.1.3 What is a Theme?
A Theme is a specific type of document presenting a description of project variables (parameters) and
the values of the variables. The ability to change the values of the variables in a project allows the
designer to vary the project scenes appearance and behavior by changing the values of the parameters
constituting the Theme.
Parameters forming a loaded scene take on their values at the project initialization (started with the
Init All button of the LiveAction toolbar, see section 3.2.2) and are used when executing Actions on
pressing the Hotbars buttons (see section 3.1.2).
There are two basic types of Themes: Standard and Custom. They differ in that the user can edit the
Custom themes (change the values of the variables), and the Standard themes are available only for
reading (loading).
A project can have only one theme loaded. For more details on work with themes, see section 3.4.

3.2 Application Main Window
The HotActionsLite application main window contains toolbars with dynamic menus for executing
different commands including project opening, themes loading and editing.
The background color can be changed. For that purpose, place a required image (a *.bmp file) named
HotActions.bmp into the C:\Program Files\Focus Software\HotActionsLite\Common\Images folder. If
the window is larger than the image from the file, the image is duplicated as many times as necessary
to fill up the window.
The Toolbars submenu of the View menu is used to show or hide the Project and LiveAction toolbars.
By default the LiveAction toolbar is docked to the right border of the main window (Docking View),
and the Project toolbar – to the upper border, on the left.
Any main window toolbar can be rendered into a „floating‟ state by dragging at its top edge with the
Ctrl key pressed. A double click on a floating toolbar title returns it to the docked state.
The functions executed by the toolbars buttons are listed in the next sections. Some buttons have
equivalent commands in the corresponding menus of the application main window. In the table they
are given in brackets.

3.2.1 Project Toolbar
The Project toolbar (Figure 10), which is usually attached to the top border of the main window,
contains commands for selecting a current project and controlling its themes. The elements of the
toolbar execute the following functions:
the Project drop-down list (the Recent Projects command of the File
menu or the Ctrl-Shift-M key combination). Allows selecting a project to
be loaded from the frequently used (last opened) ones;
(the Open Project... command of the File menu or the Ctrl-O key
combination) allows opening an arbitrary project from the Open Project
dialog;
the Theme drop-down list. Allows selecting a set of parameters values
(Theme) for a loaded project. The theme names of the Standard type begin
with an asterisk in the list (section 3.1.3);
opens the current theme window to edit or view the values of the variables,
if the theme is Standard;
Saves the current theme; if the current theme is Standard, you will be
prompted to save it as a Custom theme;
deletes the current theme; the button is available only for Custom themes.
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3.2.2 LiveAction Toolbar

Figure 12. The LiveAction toolbar.

The LiveAction toolbar, which is usually attached to the right border of the main window, contains
commands of the HotActionsLite application control. The toolbar buttons have the following
functions:
(the Init All command of the Tools menu or the Ctrl-Shift-I key combination) initializes
a project;
(the Stop All command of the Tools menu or the Ctrl-Shift-R key combination) stops
executing all the Actions and clears their queue. Besides, it stops the operations started by
clicking the buttons of all the Hotbars (section 3.1.2), as well as the Init All button;
(the Sound Configure… command of the Tools menu) opens the Sound Configure
dialog (see Focus Virtual Studio. Video and Sound Settings User's Guide);
(the Video Configure… command of the Tools menu) opens the Live Video tab of the
Options dialog (see Focus Virtual Studio. Video and Sound Settings User's Guide);
(the Exit command of the File menu) exits the application;

3.2.3 Menus
The main window contains the File, View, Tools, Window and Help menus. Many of their
commands duplicate the buttons of the main window toolbars described above.
The File menu commands (Figure 13) allow performing the following standard operations:
Open Project... (or Ctrl+O) – opens a project;
Close Project – closes a project.
Recent Projects (or Ctrl+Shift+M) – a list of the frequently used projects
Exit – exits the application.

Figure 13. The File menu of the main window.

The View menu commands allow performing the following operations:
Toolbars:
Project
LiveAction – shows or hides toolbars in the application main window;
Status Bar – shows or hides the status bar in the lower part of the main application window;
Render Window (or Ctrl+0) – shows or hides the Render Output window;
Debug Output (or Ctrl+Shift+0) – shows or hides the Debug Output window (displaying

diagnostic messages).
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Figure 14. The View menu of the HotActionsLite application.

The Tools menu contains the basic commands of the HotActionsLite application control, which allow
performing the following operations:
Init All (or Ctrl+Shift+I) – initializes a loaded project;
Stop All (or Ctrl+Shift+R) – stops executing all the Actions and clears their queue;
Exclusive Mode (or Ctrl+Shift+E) – switches both application windows (main window and the
Render Output window) from the full-screen mode to the window mode and
vice versa;
Video Configure… – opens the Live Video tab of the Options dialog;
Sound Configure… – opens the Sound Configure dialog;
Options… (or F10) – opens the Options (application general settings) dialog box.

Figure 15. The Tools menu of the HotActionsLite application.

The context menu opened by a right click on a free client space of the main window also contains
some commands of the HotActionsLite application control (Figure 16). You can select any convenient
means of control.

Figure 16. Context menu of the HotActionsLite application.

The Window menu commands (Figure 17) allow working with the following windows:
Arrange Icons – arranges minimized Hotsets windows in the bottom area of the application main
window;
Center Render Window – places the Render Output window in the centre of the application main
window.
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Figure 17. The Window menu of the HotActionsLite application.

The About HotActions Lite... command of the Help menu (Figure 18) displays a message with
information on the current application version.
The Export Encryption Key… command opens a dialog for saving the registration key (the logging
to the system register) of a project export, which allows to code projects (created in the HotActions
application on another computer) for the current system. For coding projects created in the HotActions
application in another system and the further work with them in the HotActionsLite application in the
current system, add the saved registration key to the register of the system from which a project is
coded.

Figure 18. The Help menu of the HotActionsLite application.

3.3 Operations with a Project
3.3.1 Operations with a Project File
This section covers the general outline of work with projects in the HotActionsLite application.
The HotActionsLite application works with one project at a time. The Project drop-down list of the
Project toolbar (Figure 10) allows selecting a project to be loaded from the frequently used (last
opened) ones. To open an arbitrary project, use the
button (or the Open Project… command of
the File menu of the application main window), which starts the Open Project… standard dialog. In
the dialog type the name of a required project or select it from the list of the folder. After a project has
been opened once, its name is added to the local menu of the Recent Project command of the File
menu, and the project can be opened by selecting its name in the menu.
The Close Project command of the File menu becomes available when there is an opened project in
the application (Figure 13).
When loading a project, the scene image (if present in the project) is displayed in the Render Output
window (see Section 4). Information of the open scene is displayed in the Debug Output window (see
section 3.6): the number of the mesh objects, polygons, textures, and the video adapter memory size
occupied by them.
When no project is opened in the application, the output TV monitor (see Section 4) displays the
image from the EmptyRender.bmp file. The file is located in the folder C:\Program Files\Focus
Software\HotActionsLite\Common\Images.
When reloading projects, the TV monitor displays the image from the LoadingProgress.bmp file
located in the same folder C:\Program Files\Focus Software\HotActionsLite\Common\Images.
If you want, you can change the image in either files to some different. To do so, place the required
bmp file(s) into the folder C:\Program Files\Focus Software\HotActionsLite\Common\Images. Name
the new files respectively: EmptyRender.bmp and/or LoadingProgress.bmp.

3.4 Operations with a Theme
A Theme is a set of a project variables (parameters) used in the Actions (see 3.1.2).
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3.4.1 Operations with a Theme File
All the project themes are available for selection in the Theme drop-down list of the Project toolbar
(see section 3.2.1).
A project can have only one theme loaded. There are themes of two types: Standard and Custom.
The Standard themes can be used only to load to a project and view the parameters (the Edit Theme
button of the Project toolbar, see section 3.2.1) (Figure 19). Editing the values of the parameters is
possible only for the Custom themes. Usually such themes are not included in a project, but attached
to it in the Themes\Custom special folder.

Figure 19. Window displaying possible values of a theme variables.

At attempt to change one of a Standard theme parameters, the user is prompted to save it as a
Custom theme, whose values of the variables can be changed. In the Theme drop-down list of the
Project toolbar the names of the Standard themes begin with an asterisk (*).
The

button of the Project toolbar opens the dialog for saving the current theme. It can be saved as

a theme of the Custom type only. The
type.

button of the same toolbar deletes a theme of the Custom

3.4.2 Operations with Theme Variables
As was described in section 3.1.3, the values of the variables specified in a loaded theme are inserted
to a project during its initialization (started by the Init All button of the Live Action toolbar, see
section 3.2.2) and are used when executing Actions execution on clicking the Hotbars buttons (see
section 3.1.2).
There are five types of variables:
 STRING, determines a string value; it is used, for example, to change a text fragments;
 NUMBER, sets a numerical value, determines, for example, the start position of a track animation;
 COLOR, sets a color;
 FILE, sets a variable of the „file name‟ type by the file extension mask;
 VARIANT, allows selecting from a set of predefined values (of any type) for a variable.
To view or edit the values of a theme variable, start a dialog according to the variable type. The dialog
is opened by the Edit command of the context menu (Figure 20) or a double click on the variable
name in the theme document window.
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Figure 20. Theme document window and the context menu for the theme variables.

For example, a COLOR type variable is edited in a standard color selection dialog. A FILE variable
value is specified in the Open dialog. A dialog with a drop-down list of possible values is used for the
variables of the VARIANT type (Figure 21).

Figure 21. Editing the value of a variable of the VARIANT type.

 To use the new values of the variables in Actions (executed by pressing the buttons of the
HotBars, see 3.1.2), click the Init All
button of the LiveAction toolbar (section 3.2.2) or use
the application context menu (Figure 16) to initialize the project.
not necessary to initialize the project every time a variable of a theme has been changed. Do
thatIt isonly
when the required actions in a project are to be executed with the new values of the
parameters. That is why it is recommended to initialize a project after all the values of the
variables necessary for work are changed.

3.5 Using Joystick and Mouse to Control Objects
The scene objects can be controlled (dynamically rotated and scaled) by the joystick. In the window
mode (see Section 4), the scene objects in the Render Output window can also be manipulated using
the mouse and the keyboard keys.

3.5.1 Selecting a Manipulation Object
Usually after a project is loaded, the object (node) selected for manipulation is the scene virtual
camera. It can be manipulated by the joystick or mouse (in the window mode, see Section 4). By
default the mouse movements with the left button pressed rotate the camera in the Render Output
window, and rolling the scroll wheel changes the camera focal distance.
It is possible to enlarge the variety of operations that can be performed on a virtual camera (or another
selected manipulation object) with additional keys of the keyboard:
 Tab – cyclic switching from one axis to another at rotation/movement;
 + / – – increases / decreases the speed of the camera movement starting with zero value (position
of rest of the camera after the project is loaded); decreasing the speed of the movement starting
with zero value means increasing the camera movement speed in the negative direction;
 Space – stops the camera movement, sets the movement speed equal to zero;
 Ctrl+R – sets the camera to the initial position (as it was after the project had been loaded);
 PgUp / PgDown – increases / decreases the camera focal distance;
20

 Home – sets the default camera focal distance (Zoom), as it was after the a project had been
loaded.
 Modifiers:
Ctrl – the camera is scaled along the current axis with a mouse gesture or joystick movement or
arrow keystroke;
Alt – the camera is moved along the current axis in the scene area.

3.6 Debug Output Window
The HotActionsLite application has the ability to track diagnostic, error, and warning messages and
other events. Such messages may be necessary to the developers of projects or to the developers of the
application for troubleshooting. The Debug Output window displays messages of various types
reporting the application operation. It can be opened by enabling the Debug Output option of the
View menu (Figure 14) or by pressing the Ctrl-Shift-0 key combination.
The type of messages displayed in the Debug Output window can be specified in the Options dialog of
the application general settings, which is opened by the Options… command of the Tools menu or by
pressing the F10 button in the Debug Output tab page. See section 5.2 for more detailed information
about the tab page settings. Whether the Debug Output window is opened or closed, the messages of
all the selected types are registered in the log file, whose name is specified in the application general
settings (section 5.2).
By default the Debug Output window is docked to the bottom left corner of the application main
window (Docking View). The window as well as the Project and LiveAction toolbars (see section 3.2)
can also be displayed in any part of the main window. That can be achieved by dragging it at the left
bound with the Ctrl key pressed, by pressing the
button in the left top corner of the window, or by
switching off the Docking View command of the context menu (Figure 22). To dock the
Debug Output window back to a border of the application main window, drag it to the border and
double-click it or enable the Docking View option in the context menu of the window title bar.

Figure 22. The Debug Output window title bar context menu.

The Enable Docking option must be enabled in the context menu to make the docking of the window
possible. The Hide command or pressing the
button hides the window.
The commands of the Debug Output window context menu (Figure 23) allow performing the
following operations:

Figure 23. The Debug Output window context menu.
Show Columns
Sending Time – show the column with a message receiving time; time is counted from the start

of the application session in the “hours : minutes : seconds : milliseconds”
format (the Time column);
Module Name – show the column with the name of a virtual studio software component a
message from which is received in the Debug Output window (the Module
column);
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Copy – (Ctrl+C key combination) copy the lines selected in the window to the clipboard; later the

lines can be inserted from the clipboard to any text application, for example, to
Notepad or an e-mail message; The lines are selected by the standard
operations: with the help of the left mouse button and the Ctrl or Shift keys (as
usual, when working with files in Windows). The Ctrl-A key combination is
used for selecting all the messages in the window;
Clear – delete all the messages from the window.
The icons displayed in the Message column on the left of the text ( , , , etc.) indicate the type
of a message: information about the uploaded data and modules, an error message, a command
execution message, etc. For more details about the types of messages, see section 5.2.
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4 Render Output Window
The Render Output window is intended to display the results of the studio operation (the synthesized
3D graphics image with realtime video streams). When working with the studio the window is usually
displayed on a TV monitor in the Fullscreen mode.
The Render Output window is switched from the full-screen mode to the window mode and vice versa
by enabling/disabling the Exclusive Mode option of the Tools menu or by pressing the Ctrl-Shift-E
key combination (section 3.2.3). The commands of the Render Output window control become
available in the window mode of operation.

4.1 Commands of the Application Main Window Menus for Working with
the Render Output Window
The Center Render Window command of the Window menu of the HotActionsLite application
main window (Figure 17) places the Render Output window into the center of the application window.
The Render Window command of the View menu (Figure 14) closes the Render Output window or
opens if closed.

4.2 Menu Commands of the Render Output Window
The Render Output window has its own menus as well. The View menu (Figure 24, left) of the
Render Output window contains the following commands:
 Frame Rate displays the information about the window size and some average statistical
information about the studio performance for the currently displayed scene: the minimal
time of calculation and displaying of one of the last four frames (in milliseconds).
 Standard window sizes (320х240, 640х480 and 768х576), which can also be set by the
respective key combination (Alt+1, Alt+2, Alt+3).
 Fullscreen (Ctrl+Shift+Home) allows switching to the full-screen mode. At that, the
entire application is not switched to Exclusive Mode. Switching back is performed by the
Ctrl-Shift-End key combination.
The Engine (F8) command of the Options menu (Figure 24, right) opens a dialog with the
information about the render engine module that is used in the virtual studio (Figure 26). The
Render (F11) command opens the Render Options dialog with the information about settings of the
render engine module (Figure 27). Both the dialogues are described in the next section.

Figure 24. The View and Options menus of the Render Output window.

With the help of the Tools menu commands (Figure 25) the current image of the Render Output
window can be printed (Print…) or saved to a BMP file (Take Snapshot… or Ctrl+Shift+S).
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Figure 25. The Tools menu of the Render Output window.

4.3 Dialogs of the Render Output Window Image Settings
It is not recommended to change the settings of the dialogs described below without special
instructions
of the technical support service. The settings are described for general overview.
The Select Render Engine dialog displays the information about the name, version and the path to the
render engine module used (Figure 26). It is opened by the Engine command of the Options menu in
the Render Output window (Figure 24, right). The information can be necessary to the developers and
the technical support service.

Figure 26. The Select Render Engine dialog box.

The Render Options dialog (Figure 27) contains information about the settings of the image displaying
module in the virtual studio. It is opened by pressing the F11 key on the keyboard or by the Render
command of the Options menu of the Render Output window.

24

Figure 27. The Render Options dialog.

The General area of the dialog box is used to set the general parameters of the resultant video image
rendering.
The Output Device drop-down list is used to select a device for displaying the Studio resultant video
image. The drop-down list may contain:
Display 1 (with the name of the monitor connected to it) – rendering the result of the Studio operation
is to be performed using the video adapter;
Display 2: DVM62 – rendering through the DVM62 (See Section 7) or a monitor connected to the
second output of the video adapter;
External Device: FD300 #1, External Device: FD300 #2, External Device: FD300 #3 (according to
the number of the FD300 boards installed in the system) – the image is to be rendered by the selected
FD300 board. The board number must match the logical index L of the output board in the
FDConfiguration application (Section 2.3, Figure 4). Usually it is the largest number.
Display Format – is used to select a format of the image, that is, how many bits of the 32 are
allocated to represent each croma component R(8), G(8), and B(8).
Display mode – the image resolution and refresh rate.
Output aspect – the pixel aspect ratio – in the Auto mode (determined by the monitor settings), 4:3,
16:9, or Square pixel (1:1).
The Advanced area contains parameters for the image rendering fine-tuning: for window mode
(Windowed) and full-screen mode (Fullscreen).
Back Buffer Format – a format of picture coding in bits for each croma component (RGB);
Stencil Format – the number of bits of the 32 allocated to determine the Z order (D24) and used to
store the object number in the scene (X8).
Present Interval – the frame rendering rate. When DEFAULT, the value is equal to the horizontal
scan rate, as well as when ONE. The ОNЕ mode differs from DEFAULT in more precision and
activating more resources. In the IMMEDIATE mode, a frame is rendered on the monitor irrespective
of its horizontal scan rate, the output time being the full rendering time.
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Multisample Type – a mode of smoothing when rendering. When NONMASKABLE, 4_SAMPLES
and 8_SAMPLES are selected, the level of smoothing can be variated by the Multisample Quality

slider located below. The recommended value is 7 in the 4_SAMPLES mode;
Back Buffers Count – the number of half-frames stored into the buffer before rendering.
The Device Type drop-down list is used to select a type of the device which is to be used for the
image rendering. Hardware – the graphics accelerator of the video card; Reference – the image is to be
rendered in one of the DirectX modes (that is, the central processor of the motherboard is to be used).
Vertex Processing – is used to select a means of geometric transformations:
Software – transformations are performed by the central processor. Recommended when working with
graphics processors of no high capacity and/or with scenes having a large quantity of dynamic objects
(e.g., using morphing).
Hardware and Pure hardware – transformations are performed by the video card graphics processor,
but when selecting Pure hardware, the data transmission of the transformation results is impossible,
which allows to optimize the process in the best way. Optimal when working with scenes having a
large quantity of static objects.
Mixed – the selection of a transformation means is performed programmatically from those described
above.
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5 Options Dialog: Virtual Studio General Settings
The Options… command of the Tools menu or the F10 key opens the Options dialog for adjusting
the НotActionsLite application settings.

Figure 28. The Options dialog of the application settings.

5.1 Default Directories Settings
On the Default Directories tab page (Figure 28) you can examine which directories are set for
searching files of different types (projects, icons, media files, Action Libraries, etc.) used by the
application When loading any project and working with it. Some of the settings on the tab can be
changed, but for some of them the button for browsing is disabled.
Usually all the necessary files (scenes, Action Libraries, etc.) are saved in the project when creating it
and exporting from the НotActions application. But it may be inexpedient to save a file of a large size
in the project (for example, a video file). In that case such a file can be not saved in the project but
used when working with it through the directories for different file types specified in the project (the
local settings in the НotActions application) or in the Default Directories tab of the Options dialog in
the НotActionsLite application. At that, the required file should be located in the directory intended for
files of the corresponding type (Images, Sounds, Videos, etc.).
When working with a project, files of any type whose names are specified in the commands of the
project (Actions) are searched in the following order:
1. In the current project.
2. In the current project folder, i.e. in the folder where the project file (*.vsz) is saved.
3. In the folders for a specific file type assigned to the project (local settings).
4. In the folders for a specific file type in the Default Directories tab of the Options dialog.
If a required file is not found by any path specified for it, a message about that is displayed in the
application main window (Figure 29) or the Debug Output window (Figure 22). For that purpose,
enable the Errors option on the Debug Output tab of the Options dialog described in detail in the
next section.
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Figure 29. Error message: The Action Library file is not found in the project.
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5.2 Debug Output Settings
The Debug Output tab page (Figure 30) contains the control options of the messages displayed in the
Debug Output window when working with the application.

Figure 30. The Debug Output tab page.

According to the options selected in the tab the following messages can be displayed in the
Debug Output window:
 Errors – error messages;
 Warnings – non-critical warnings;
 Info
– various information about the loaded data, program modules, etc;
 Runtime (from Actions) – user messages about the Actions execution; displaying such messages
should be enabled by the creator of a project for work in the НotActions Lite application;
 Script Trace – information about the course of the Action commands execution; used for scripts
debugging;
 Debug Messages – various debugging messages about the application work (mostly necessary to
the developers);
 System Debug Strings – system debugging information (also intended for the developers): if
enabled, the application traps and displays all the debugging messages of the applications running
in the Windows and using the OutputDebugString system command;
 General (No type) – all the other (not typified) messages.
The All and None buttons allow enabling/disabling all the options simultaneously.
The icons on the left of each option correspond to the icons that will be displayed in the Debug Output
window as well (see section 3.6), on the left of the message text according to the type. Thus, the icons
identify the types of messages.
The Log File Name field is used to specify the name of a log file for logging the messages of all the
selected types. A text file with the name will be created in the Windows directory for temporary files
of the current system user. The default file name is HotActions.log. Messages of all the selected
types are registered in the log file when working in the application whether the Debug Output window
is opened or closed.
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The path to the Windows directory containing temporary files of the current system user can be found
in the Environment Variables dialog. The dialog is opened as follows:
1. Right-click on the My computer icon on the Windows desktop. The context menu opens.
2. Select the Properties command, the System Properties dialog opens. Select the Advanced tab
(Figure 31, left) and press the Environment Variables button.
3. In the Environment Variables dialog place the mouse cursor on the User variables for ... list
(Figure 31, right), where the current user name is specified in place of the ellipsis.
4. Find the variable named Temp in the Variable field. The Value field of this variable displays the
path to the Windows temporary files directory, where the log file for the debugging messages will
be located.

Figure 31. The Advanced tab page with the Environment Variables button (on the left)
and the dialog of the same name (on the right).

The log file with a list of the required debug messages can be sent to the developers for
troubleshooting. Possible problems and solutions are described in the next section.

5.3 Language Tab
The Language tab of the Options dialog is intended to select a language for working with the
application. The text of the information messages, menu items, prompts and user controls will be
displayed in the selected language.
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Figure 32. The Language tab page of the Options dialog.

The list of languages presented in the tab depends on the components included in the application
installer intended for usage in a specific country.

 The names of all the languages are always displayed in English.

After changing the language and exiting the Options dialog by pressing the ОК button, the application
must be restarted.
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6 Troubleshooting
In case of a problem not described in this section, apply to the technical support service (section 6.4).
To establish the cause of a problem you may need the log file with the debug messages. The file is
named HotActions.log by default and is located in the folder for temporary files of the current system
user (about using debug messages, see sections 3.6 and 5.2).

6.1

Problems with Default Directories

At the application start-up, a dialog for selecting a working folder, for example, for the project files,
icons (Figure 33), scenes, libraries, Hotsets, graphics, audio and video files is displayed.
The dialog is displayed if the Common folder with all the standard working folders was not created
for some reason when setting up the application (or reinstalling updates), or if the folder specified in
the Default Directories settings of the application (see section 5.1) is absent, for example, if it was
deleted.

Figure 33. Dialog for selecting a folder with the standard icons for buttons.

To create the Common folder with standard working folders of the application, you can reinstall
HotActionsLite.
If the reinstallation has no effect, or other non-standard working folders are used and the application
could not restore paths to them from the register, it is possible to specify the path to the required folder
in the dialog displayed (Figure 33) or change the path in the Default Directories tab of the Options
dialog (see section 5.1).

6.2 Problems with FD300 Board(s)
6.2.1 One or Several Boards are not Found in the System
If the number of the list entries about FD300 boards under Board's Indexes of the FDConfiguration
application (Figure 2) does not match the number of boards installed in the system, it is necessary to
make sure whether the boards are correctly presented in the Device Manager dialog box of the
operating system.The dialog is opened as follows: Start > Settings > Control Panel > System >
Hardware
>
Device manager.
If
the
board
is
not
found
in
the
Sound, video and game controllers section of the dialog (the corresponding inscription SoftLabNSK FD300C Card is not displayed), the board, most likely, does not physically contact with the slot.
In that case it is required to switch off the computer power supply and check whether the boards are
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tightly set in the slots. It is also possible that one of the boards is invalid, in that case apply to the
technical support service (section 6.4).
If a board is found in the system, but not identified as SoftLab-NSK FD300С Card, perform the
following operations:
1. Delete all the incorrectly installed boards from the system devices list. To do that, right-click on
the icon of each board and select the Delete… command in the context menu.
2. Right-click on the section title and select Update driver in the context menu.
3. The system will find the new devices and install the corresponding drivers if the software was
installed correctly.

6.3 Problems with Output Video
6.3.1 Absent Render Output Window
Make sure the Render Window command of the View menu is enabled (Figure 14) and execute the
Center Render Window command of the Window menu (Figure 17).

6.4 Technical Support Service
For complete consultation on all the questions concerning the work with the virtual studio, apply to the
SoftLab-Nsk technical support service by the following address:
vrset@sl.iae.nsk.su
SoftLab-Nsk, Novosibirsk, www.softlab-nsk.com
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7 Connecting Video Signals and Configuring HD Virtual
Studio
7.1 The Studio Components Connection Scheme
To work with HD-SDI video signals, the Virtual Studio uses input boards Aja Xena 2Ke. The video
signal sources are connected to the board connectors. The operating system must have drivers for
board version 7.1.0.10 (installation file AJA_Windows_Software-4.2.0_x86.msi).
Connect a switching device to the FD300 board (the cable set and Breakout Box are described in
Section 8, Appendix) to have the audio signal sources and receivers connected.

Figure 34. Connecting video signal sources to the Aja XENA 2Ke board and a switching device to the
FD300 board.

The HD Studio resulting image is output through the DVM62 converter connected to the second
connector of the video card. The first connector is used to connect the VGA monitor. If it is analogous,
the connection is performed via a DVI - D-SUB adapter.

Figure 35. Connecting the Studio output video signal converter to one of the video card connectors.

When the connections are complete, connect DVM 62 to power supply and flick the Power switch (on
the front panel) to On.
The video signal receivers are connected to the back panel connectors. It may be the upper group (A1,
A2, A3, A4) or the lower group (B1, B2, B3, B4). If required that the Studio video signal frequency be
synchronized with an external source, connect the video source to connector G3 of the Genlock group.
The front panel contains buttons that determine the output video signal format.

7.2 Setting the Video Card to Work in a Configuration with Two
Monitors
When the connections are properly done, and the computer is started, check whether the
NVIDIA GeForce video adapter is properly set.
To do so, open the Display Properties dialog box (Figure 36) using the Start menu: Start –>
Settings -> Control Panel –> Display or right-click on the desktop and select Properties in the
local menu.
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In the Settings tab of the dialog box, select 1. Plug and Play Monitor on NVIDIA GeForce 8800
GTX for the monitor icon 1 in the Display drop-down list.
Select Highest (32 bit) from the Color Quality drop-down list,.
For the monitor icon 2, select 2. Plug and Play Monitor on NVIDIA GeForce 8800 GTX from the
Display drop-down list and enable the “Extend my Windows desktop onto this monitor” option
located in the lower part of the dialog box

Figure 36. Setting the NVIDIA GeForce video card to work in a configuration with two monitors.

It is also necessary that the required standard be selected in the video adapter settings. To do so,
perform as follows:
1. Press the Advanced button in the lower right part of the Display Properties dialog box. The
Plug and Play Monitor and NVIDIA GeForce GTX 280… dialog box opens (Figure 37).
2. Select the Monitor tab and disable the option Hide modes that this monitor cannot display
under Monitor settings.
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Figure 37. Dialog box for setting the monitor properties.

3. Select the Adapter tab (Figure 38). Click the List All Modes button. The List All Modes dialog
box opens. Select the required mode.

Figure 38. Dialog box for setting the second video adapter of the video card.

To further set the Virtual Studio for operation, refer to Section 2.1, that covers the initial setup stages.
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8 Appendix
8.1

A Set of Cables for the FD300 Board

Figure 39. Cable for connection of the input and output audio and video signals to the FD300 board.

A complete set of cables has 28 connectors corresponding to the connectors on the passive breakout
box (except for SPDIF). All the connectors are marked according to the following rules.
All the video inputs are divided into three identical groups for handiness; each of them has the
inscription Vin and a number of the input group. Each group contains 4 coaxial connectors (A, B, C,
D). Depending on the device operating mode the following signals can be received on the video
inputs:
 on input A (Vin1A, Vin2A, Vin3A) – CVBS-A, LUMA-AB, CSYNC;
 on input B (Vin1B, Vin2B, Vin3B)– CVBS-B, CHROMA-AB, Y, YS, G, GS;
 on input C (Vin1C, Vin2C, Vin3C) – CVBS-C, LUMA-CD, U,B;
 on input D (Vin1D, Vin2D, Vin3D) – CVBS-D, CHROMA-CD, V, R,
where:
 CVBS – composite video signal;
 LUMA, CHROMA – the S-video signal constituents;
 Y, U, V – the YUV component signal constituents;
 R, G, B – the RGB component signal constituents;
 CSYNC – a single signal of the component input synchromix;
 YS, GS – a component input synchromix is contained in the Y or G constituent.
The video output connectors Red Green, Blue, CVBS, correspond to the RED/V/C, GREEN/Y,
BLUE/U/CVBS and CVBS/CSYNC video outputs. The possible combinations are presented in Table
1. For more detailed information about switching video inputs, see section 2 of FD300 Board.
Hardware Setup.
The audio inputs are marked: Ain1L, Ain1R; Ain2L, Ain2R; Ain3L, Ain3R.
The audio outputs: Aout1L, Aout1R; Aout2L, Aout2R; Aout3L, Aout3R, where L – the left channel
of stereo signal, R – the right channel.
The complete set of cables is connected, as a rule, to the FD300 boards for the image output.
A set of cables connected to the board for inputting video signals to the studio has only 8 connectors,
as there are no commutation for working with audio (audio connectors), connectors for the video
output, there being only the video input connectors of the two groups: Vin1 (A, B, C, D) and Vin2 (A,
B, C, D).
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8.2

Passive Breakout Box (TF782)

The passive breakout box (Figure 40, left) is intended to connect analog video and audio sources and
signal receivers. It is connected to a connector on the FD300 board with a special cable (Figure 40,
right) supplied with the box.

Figure 40. Front appearance of the passive breakout box with the connection cable.

The front appearance of the passive breakout box is shown schematically in Figure 41. All the video
inputs are divided into three identical groups; each of them has a frame with the inscription
VIDEO INPUT and a number of the input group. Each group contains 4 coaxial connectors (A, B, C,
D). Depending on the device operating mode the following signals can be received on the video
inputs:
 on input A – CVBS-A, LUMA-AB, CSYNC;
 on input B – CVBS-B, CHROMA-AB, Y, YS, G, GS;
 on input C – CVBS-C, LUMA-CD, U,B;
 on input D – CVBS-D, CHROMA-CD, V, R.
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Figure 41. Passive breakout box scheme.

The video outputs are presented by the VIDEO OUTPUTS group, where the 4 outputs RED/V/C,
GREEN/Y, BLUE/U/CVBS and CVBS/CSYNC are located. The possible combinations are presented
in the table below.
Table 1 Combinations of the video outputs.
VIDEO OUTPUTS group connectors

Possible
combinations

RED

BLUE

GREEN

CVBS

Y/C+CVBS

C(Chroma)

CVBS

Y(Luma)

CVBS

YUV+CVBS

V

U

Y

CVBS

YUVS

V

U

Y

Sync

RGBS

R

G

B

Sync

YUV+Key/α

V

U

Y

Key/α

You must NOT receive the Y/C (S-video) signal simultaneously from the miniDIN-4 S-VIDEO
connector
and GREEN (Y – brightness signal) and RED (C – color information) connectors.
Chroma signal (С) should be loaded at 75 ohm. Some SONY equipment (monitors, videotape
recorders)
does NOT have such loading and it should be provided for.
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The audio signals are divided into 2 groups: the output signals – AUDIO OUTPUTS, input signals
AUDIO INPUTS. Each group has six patchholes in three L-R stereo pairs.

8.3

Active Breakout Box (TF785 M)

Figure 42. Front appearance of the active breakout box.

There are 3 identical channels of VIDEO INPUTS (Figure 43) on the active breakout box (Figure 42).
Each channel contains four pairs of parallel-connected through-pass BNC coaxial connectors (A, B, C,
D), and also 2 MiniDIN4 connectors for the connection with the sources of S-video (inputs AB and
CD). The connectors used are selected with the COAXIAL/S-VIDEO switches. The OFF/ON switches
are intended to connect/disconnect the 75-ohm terminal resistors of the corresponding coaxial video
input.
Depending on the device operating mode the following signals can be received on the video inputs:
 on input A – CVBS-A, LUMA-AB, CSYNC;
 on input B – CVBS-B, CHROMA-AB, Y, YS, G, GS;
 on input C – CVBS-C, LUMA-CD, U,B;
 on input D – CVBS-D, CHROMA-CD, V, R;
where:
 CVBS – composite video signal;
 LUMA, CHROMA – the S-video signal constituents;
 Y, U, V – the YUV component signal constituents;
 R, G, B – the RGB component signal constituents;
 CSYNC – a single signal of the component input synchromix;
 YS, GS – a component input synchromix is contained in the Y or G constituent.
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Figure 43. Active breakout box scheme.

When a component signal with the YS or GS constituent is sent to the channel video input, the
YES/NO switch should be in the YES position. In all the other cases it should be in the NO position
(normal position).
There are also four video outputs (RED/V/C, GREEN/Y, BLUE/U/CVBS, CVBS/CSYNC) on the box
combined into the VIDEO OUTPUTS functional group. Each video output is duplicated, which allows
connecting a preview monitor simultaneously with the working signal.
Six patchholes grouped in three L-R stereo pairs form the AUDIO INPUTS functional group. All the
audio inputs are balanced, for which three-pole stereo plugs are used. The OFF/ON switches are
intended to connect/disconnect the 600-ohm terminal resistors of the corresponding audio input.
The AUDIO OUTPUTS functional group is formed by six balanced audio outputs. They can be used as
unbalanced ones with the earth connection of one balance line, the same way as the audio inputs.
There is a patchhole for a stereo headphone connection in the AUDIO MONITOR HEADPHONE
group. The output level can be set by the VOLUME controller. The number (1, 2 or 3) of an audio
output for listening is selected by the SELECT switch. The MODE switch allows setting the necessary
mode: LR – stereo, LL – left channel only, RR – right channel only.
The POWER light-emitting diode indicator shows the power supply availability.
If the POWER LED indicator is not alight after the FD300 board is connected to the active
breakout
box, apply to the technical support service (section 6.4).

8.4

Breakout Boxes for a System with Several FD300 Boards
(TF783 A, TF783 B, TF783 C)

If several FD300 boards are installed in the system, and it is desirable to perform all the necessary
connections of audio and video sources and signal receivers on the same breakout box, the TF783 A,
TF783 B or TF783 C boxes can be used for that purpose (Figure 44).
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Figure 44. Front appearance of the breakout boxes for connecting several FD300 boards.

Usually, the TF783 A Breakout box is used in the systems with two FD300 boards for video data input
and with the option of synchronizing the output video signal to an external device. At that, the
VIDEO INPUTS 1 (A, B, C, D) and VIDEO INPUTS 2 (A, B, C, D) groups are intended to connect
video sources to the first board decoders, the VIDEO INPUTS 3 (A, B, C, D) and VIDEO INPUTS 4
(A, B, C, D) groups – to connect to the second board, the VIDEO INPUTS 5 group – to connect the
external synchronization device. The video outputs are presented by the VIDEO OUTPUTS group:
RED/V/C, GREEN/Y, BLUE/U/CVBS and CVBS/CSYNC. The input AUDIO INPUTS and output
AUDIO OUTPUTS audio signals are always connected to the FD300 board intended for the signals
output.
The TF783 B Breakout box and TF783 С Breakout box are usually used only for the input signals
connection.
The cable used to connect the breakout boxes described above to the FD300 boards is also supplied in
the package with the breakout box (Figure 45).

Figure 45. The cable for connecting FD300 boards to the breakout box.

The cable branches are intended for the connection with the FD300 boards. Usually there are color
marks or numbers at the ends of branches for determining the correspondence of connection to the
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boards. A connection type is usually determined by the current system configuration file with the *.cfg
extension located in the folder С:\Program Files\ForwardT Software\FDConfig next to the
FDConfig.exe file. The name of the file should be selected in the Breakout Box Cable Connectors
drop-down list in the FD300 Configuration application. All the available configuration files are also
usually located in the C:\Program Files\ForwardT Software\FDConfig\CableInfo folder.
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